Important Update for v12.5, v12 & v11 Users

Recent SSL changes (revoking of SHA-1 certificates by Google for security purposes) will force us to update our licensing server in the coming weeks, and in turn to reactivate 3CX Phone System, you will need to have applied the latest service pack for your 3CX Phone System. Reactivation is not immediately required but its best to be prepared in case you have network changes that would require reactivation (change of public IP, Mac address etc.). Included in this service pack is also a security update. Upgrading to the latest service pack is an easy process which takes just a few minutes & mouse clicks:

  • V12.5 users – Access the management console > Updates node > 3CX Service Pack Updates and Download Update 1 – License Update – Build 41543.
  • V12 users – Access the management console > Updates node > 3CX Service Pack Updates and Download Update 6.2 – License Update – Build 41311. For users who do not have valid maintenance: Your maintenance has been extended until 15th July 2015 which allows you to install the update.
  • V11 users – Access the management console > Updates node > 3CX Service Pack Updates and Download Update 4B – License Update – Build 30296.

Liked this article?

Get notified of new articles
or share
You might also be interested in:
  1. Moses Adeniyi

    Dear All,

    Please be informed that we currently run a 256 user license on V12 and currently working on the maintenance.

    We will like to know if we can go ahead with the upgrade to avoid failure due to SHA-1 certificate issue.


    June 1, 2015 at 1:13 pm
    • Hi, You dont need to upgrade, just apply the service pack as per the blog post? If you dont have maintenance please email us at so we can help you

      June 1, 2015 at 1:15 pm
    • Orlin Shopov

      Will failure to apply latest service pack means at certain moment PBX will revert to free license ?

      June 1, 2015 at 1:46 pm
  2. kunal jain

    how do we manually reprovision the phoens. the reset and reproivision tab is not showing highlited. it is showing grey.

    June 1, 2015 at 4:08 pm
    • This would be a question for support.

      June 1, 2015 at 4:15 pm
  3. Jimmy

    After upgrading, the time in log report is all out.
    How do i adjust it back?

    June 2, 2015 at 1:15 pm
    • This blog post refers to updating only. If you are upgrading from a version to another version, please contact tech support and provide additional details. Such as from which version to which version. Please note that v11 is EOL.

      June 2, 2015 at 1:22 pm
    • Stuart Hash


      how do we contact support with access to the Support portal?


      June 21, 2015 at 1:22 am
    • You need to have a support account to access the support portal. Support pricing is on our website

      June 21, 2015 at 1:13 pm
  4. Lorenzo Mariscal

    Hi, I’ve update my 3CX to v 12.5, but in “Settings > Activate Licence” it say’s Version Number 12, aand in “Updates > 3CX Servcie Packs Updates/Updates” I have only Service pack1 – Critical License Update I have the Status “up to date”, and that’s the only one, how can I know I have ver 12.5 ?

    June 2, 2015 at 10:11 pm
  5. Stuart Hash

    v12.5 issues
    -no windows management console
    -cannot edit phone provisioning templates in web management console
    -firewall checker reports port mapping issue on ports 5060 and 5090, we did not have this issue in v12.0 as Sonicwall does not have Static Port Mapping. this is a new issue only affected in v12.5

    June 21, 2015 at 1:15 am
    • The firewall checker correctly detects that firewall is not configured properly. You need static port mapping and you best check our blog on how to configure and update sonicwall. Windows management console has been deprecated and you can edit phone templates from the web console.

      June 21, 2015 at 1:14 pm
    • Stuart Hash

      still having trouble getting into edit templates. its says MS Internet Explorer editing templates not allowed. IE is a major browser, it should be supported shouldn’t it?

      August 20, 2015 at 12:26 am
  6. Deke Rhinehart

    What if I missed the July 15th deadline? I’m showing the 6.2 update (says out of date) it won’t let me check the box and download it :(

    July 23, 2015 at 8:25 pm
    • Charalambos Eleftheriou

      @Deke, Thank you for your question. It may be that your Maintenance has expired, you will have to contact your sales representative to look in to this for you. Thanks

      July 24, 2015 at 9:29 am
  7. Spring

    i am using version 12 sp6. If my maintenance license was expired can i upgrade to version 12.5

    August 17, 2015 at 10:00 am
    • Spring

      Please Advise.

      August 18, 2015 at 6:04 am
    • Spring

      So you mean that if my 3CX maintenance license is expired (current version 12 sp6) i can still download new version (12.5) and install?

      August 18, 2015 at 11:32 am
    • Charalambos Eleftheriou

      @Spring, In this case you can not upgrade to v12.5 or v14 without maintenance. You will need to contact our sales department to renew your maintenance so that you will be able to activate your license on v12.5 or v14.

      August 18, 2015 at 12:16 pm