Options   hangup

Board index  >  Categories  >  3CX Phone System - General

Post Reply
hangup

Quote
hangup
by abouelric » Mon Jan 19, 2009 5:58 pm
Hello every one,
When users are dialing from Xlite or Bria softphone (extension to extension or extension to pstn), sometimes the session does not disconnect although they hang-up. This was noticed for users dialing from a different subnet. example: 3cx IP is 192.168.1.22 and the caller IP is 192.168.2.154

The FXO gateway is SPA3102 and configured according to 3cx configuration manual.

I appreciate if anyone can help.
Thank you
Ricardo

Quote
Re: v7.0.4744 does not hangup
by William400 » Mon Jan 19, 2009 10:42 pm
Hi

When you say different subnet are we talking about a different site that is across NAT or a different LAN segment in the same site with no NAT in between? Can you explain the setup?

Does a Wireshark ladder of such a call show a BYE from the Xlite to the 3CX server? Does the 3CX server return an OK to the BYE? likewise is the BYE sent form 3CX to the SPA, and does the SPA respond?

Quote
Re: v7.0.4744 does not hangup
by abouelric » Tue Jan 20, 2009 6:48 pm
Dear William400,
Thank you for your reply, what i mean by different subnet is that i have two different offices in two different countries and they are connected through a tunnel from both sides using juniper firewalls. I don't know what you mean by accross NAT but what i can tell you that all the ports are open, any ip in 192.168.1.0 can see any ip in 192.168.2.0, pingable with no restrictions.
what is wireshark ladder and how can i check it?
thank you
Ricardo

Quote
Re: v7.0.4744 does not hangup
by discovery1 » Tue Jan 20, 2009 9:42 pm
Wireshark is a network protocol analyzer for Unix and Windows. It allows you to capture packets to help analyse a SIP call

http://www.wireshark.org/

Quote
Re: v7.0.4744 does not hangup
by abouelric » Tue Jan 20, 2009 10:32 pm
I have done some research and apparently my issue is solved, i changed the spa3102 PSTN diconnect tone to: 440@-35,440@-35;1(.250/.250/1+2)
I have done some tests and it seems working.
If the problem occured again, will get back to this forum
Thank you all

Quote
Re: hangup
by abouelric » Tue Feb 10, 2009 5:10 pm
Hi,
This issue is happenning only when a user calls from a different subnet than 3cx subnet to another user or pstn on his subnet. example:
3CX IP is 192.168.1.22 and the User ext 200 (SPA941 or SPA3102 IP: 192.168.2.13) is calling a (SPA3102 IP: 192.168.2.112) ext 200 or pstn line 10002.

the web pages of the spa 3102 and Spa 941 shows that the lines where disconnected and they are idle while on 3cx are connected.

if the call is from a different subnet to any user on 3cx subnet the call disconnects normally, example:
3CX IP is 192.168.1.22 and the User ext 100 (SPA941 or SPA3102 IP: 192.168.1.11) is calling a (SPA3102 IP: 192.168.2.112) ext 200 or pstn line 10002.

I have also used bria or xlite and the same issue is noted.

So Any solution for this issue?
thank you
Ricardo