1.0.0 3CX Tunnel App disconnecting

Discussion in 'iOS' started by coreybrett, May 4, 2012.

Thread Status:
Not open for further replies.
  1. coreybrett

    Joined:
    Apr 12, 2010
    Messages:
    72
    Likes Received:
    0
    Device Info
    -------------------------------------------------------
    Phone Model: [iPhone]
    Generation: [3GS]
    Firmware Version: [5.16.05] "modem firmware"?
    Jailbreak: [NO]
    Cydia Installed: [what?]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone]
    Contacts: [Google]
    Connection: [WiFi]
    Server: [External]

    How do I keep the 3CX Tunnel App from losing it’s connection?

    It connects and works fine, but when I’m not actively using the 3CX Phone, the tunnel disconnects and therefore I don’t receive calls. The phone has been in the same room as the AP with airplane mode on and WiFi turned on.

    I’m using...
    3GS iPhone with iOS 5.1
    Linksys router with static public address and port-forwarding the tunnel port to the 3CX server.
    3CX v10sp6
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Could it be the WiFi connection that is actually dropping? Perhaps a standby mode to save batteries? Is there a set time at which it drops?
     
  3. cjferoussis

    Joined:
    May 5, 2012
    Messages:
    3
    Likes Received:
    0
    Hello,

    I have the same problem in two i-phones but they disconnect after some inactivity even they both have 3g and wifi connection to internet.
    iPhones: 3GS and 4
    Firmware: iOS 5.1

    It would be good if anybody finds the solution.
     
  4. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Device Info
    -------------------------------------------------------
    Phone Model: [iPhone]
    Generation: [3GS]
    Firmware Version: [5.1]
    Jailbreak: [NO]
    Cydia Installed: [NO]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone]
    Contacts: [Local]
    Connection: [WiFi]
    Server: [Internal]

    I have exactly the same problem as the owner of this thread.
    After 20-70 min the tunnel lost its registration to the LAN network.
    The phone is in the same room as the AP and WiFi is turned on.

    I’m also using
    Draytek v2130 - port 5090 fwd to 3CX svr
    3CX v10 SP6
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. coreybrett

    Joined:
    Apr 12, 2010
    Messages:
    72
    Likes Received:
    0
    I've been pinging the iPhone from a wired desktop non-stop without errors in the same time frame that the tunnel disconnects.
     
  6. coreybrett

    Joined:
    Apr 12, 2010
    Messages:
    72
    Likes Received:
    0
    Just found this in the phone's settings menu.
    Maybe this has something to do with it. It's several pages long and there were several of them. (Perhaps for each disconnect.)

    Image no longer available
     
  7. coreybrett

    Joined:
    Apr 12, 2010
    Messages:
    72
    Likes Received:
    0
  8. jalmendro

    Joined:
    Jun 1, 2012
    Messages:
    3
    Likes Received:
    0
    It seems that tunnel disconnects after a time, regardless of activity. I've lost tunnel connection during a call (I was connected with wifi and superb signal)
    Another bad behaviour is that, once tunnel connection is lost, it doesn't reconnect again. This is particularly bad not only by the fact of tunnel going down after a time, but whenever you change network (from wifi to 3G for instance), tunnel will go down (this is normal), but if it doesn't connect again, you will be incommunicated, as you can't receive calls.

    Although tunnel is a great idea, I think that until these issues don't be solved, iphone sip client won't be usable in practice.
     
  9. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,199
    Likes Received:
    79
    check if the post is not already answered: http://www.3cx.com/forums/v1-1-5-3cx-tunnel-behaviour-29607.html
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. ekoloda

    Joined:
    Aug 21, 2012
    Messages:
    9
    Likes Received:
    0
    Has anyone found the solution? Tunnel disconnects after a certain period of time on Phone and you have to re-connect it. It's very annoying.
     
  11. nikkoo

    Joined:
    Sep 30, 2012
    Messages:
    1
    Likes Received:
    0
    Could it be the WiFi connection that is actually dropping?
     
  12. dlazure

    Joined:
    Nov 5, 2012
    Messages:
    65
    Likes Received:
    0
    Dont look too far the app is not reliable at this time and will probably get fix soon
     
Thread Status:
Not open for further replies.