15 min dropped calls - T42G Yealink Phones

Discussion in '3CX Phone System - General' started by canden, Feb 1, 2018.

Thread Status:
Not open for further replies.
  1. canden

    Joined:
    Nov 7, 2016
    Messages:
    5
    Likes Received:
    0
    Hi all,

    Been struggling with this one for a long time. Sporadic 15 min disconnects. Firmware is constantly at the latest level 29.82.0.20. There is no SIP ALG (Using Meraki MX).

    The disconnect appears to be outbound primarily, at least on the 15 minutes disconnect. They have run into the 30 minutes disconnect on inbound calls too.

    SIP provider is voip.ms - they recommend lowering the registration expiry to 3-5 minutes - not positive about that though.

    Any insight or assistance would be greatly appreciated.

    Thank you
     
  2. simply7

    Joined:
    Jan 4, 2016
    Messages:
    38
    Likes Received:
    17
    Not sure on your firewall settings but you may have a UDP session timer that needs modified.
     
  3. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
  4. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
    Are the drops on extension to extension or external calls in or outbound? What is your internet connection health look like? Latency, jitter, dropped packets, etc?
     
  5. simply7

    Joined:
    Jan 4, 2016
    Messages:
    38
    Likes Received:
    17
    How about a packet capture and see if there is a BYE message being sent by the remote party? I bet you may learn the root cause with a capture. I would honestly do a port mirror and not the capture on the PBX.
     
  6. canden

    Joined:
    Nov 7, 2016
    Messages:
    5
    Likes Received:
    0
    It appears to be primarily on outbound calls - yesterday was particularly bad apparently. Other times it can be weeks between drops. I have not heard of any problems between sets, but I don't think anyone has ever had an internal call that lasted longer than 20 seconds either.

    • The connection is a single cable internet connection.
    • Latency between 10 and 16ms for the past week.
    • Loss is sitting at less than 0.40 percent for the same time period.

    I do have a fair number of these types or errors, but have been ignoring them for the most part - the numbers are not in service or come back busy when I try to call them from a landline / cell.

    Call or Registration to 123-456-7890 (Ln.10000 Generic VoIP Provider) has failed.
    IP Address replied: 503 Service Unavailable; from IP
     
  7. canden

    Joined:
    Nov 7, 2016
    Messages:
    5
    Likes Received:
    0
    Just confirming, you mean a port mirror on the phone's network port?

    I forgot to mention, Cisco Catalyst switch in case that makes any difference.
     
  8. simply7

    Joined:
    Jan 4, 2016
    Messages:
    38
    Likes Received:
    17
    Correct, port mirror.
     
  9. Brian Cross

    Brian Cross New Member

    Joined:
    Jul 26, 2017
    Messages:
    109
    Likes Received:
    27
    Do they ever hit the bandwidth cap on the cable modem? I had a client that would spike and the cable modem would drop all calls when that happened. I had to setup some QOS rules to reserve bandwidth. Issue went away. Maybe look in that direction?

    What Voip provider are you using? Is the trunk configured correctly?
     
  10. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,443
    Likes Received:
    282
    Hello @canden

    Are the calls dropping always at the 15 or 30 minute mark? Are the phones local or remote to the server?
     
Thread Status:
Not open for further replies.