20 to 30 second delay calling anyone (even internal)

Discussion in '3CX Phone System - General' started by bunter12345, Jan 19, 2015.

Thread Status:
Not open for further replies.
  1. bunter12345

    Joined:
    Mar 31, 2011
    Messages:
    5
    Likes Received:
    0
    I have setup 3CX in a datacentre and am connecting 2 handsets, 1x Yealink T28P and 1x Cisco SPA504G. Both handsets seem to provision fine and I have stun requests disabled as the system is using a static public IP address.

    The problem is when I try to dial one handset to the other, or voicemail, or anything else for that matter, there is a 30 second delay before the other handset rings, sometimes i can then answer OK and other times the handset keeps ringing even after the call has gone to voicemail.

    The only lead I can see is that the Cisco handset says "contacting stun server" every time I try to dial someone even though it is disabled in settings.

    All of my firewall ports are forwarded correctly.

    Any ideas gratefully received.

    Many Thanks
     
  2. jasit

    jasit New Member

    Joined:
    Feb 12, 2013
    Messages:
    170
    Likes Received:
    1
    Are you using the internal IP address of your server, or the external address? Sounds like the external, also check to see if your router supports Sip ALG, it will need to be disabled.


    jasit
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,563
    Likes Received:
    245
    I'm assuming that these are remote extensions. Obviously, there is still something left in that is trying to make use of STUN.
    You can also have a look through the 3CX logs for one of the calls. this will tell you whether the delay is happening within 3CX, or before the call even "hits" the PBX.
     
  4. bunter12345

    Joined:
    Mar 31, 2011
    Messages:
    5
    Likes Received:
    0
    Disabling the SIP ALG on my router has done the trick. All seems to be working great now, many thanks for all the help.
     
Thread Status:
Not open for further replies.