3 recurring errors after install in server activity log

Discussion in '3CX Phone System - General' started by Powdasnow, Dec 11, 2008.

Thread Status:
Not open for further replies.
  1. Powdasnow

    Joined:
    Dec 11, 2008
    Messages:
    4
    Likes Received:
    0
    ISSUE:
    Installed version 7.0.4249.0 on a 2 Ghz Pentium 4 machine with 2 GB RAM and SP3 Windows XP Pro.
    Nothing added to the system, no gateway, no extensions, really nothing, so it's an empty configuration.
    All 10 services are successfully loaded according to the section '3CX Phone System -> Services Status'
    However, every so many seconds the 3 errors down below reoccur in the server activy log:

    18:55:05.968 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=85749416f2781379 cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.968 [CM502001]: Source info: From: "Unpark line"<sip:*1@127.0.0.1:5060>;tag=8e6b266d; To: "Unpark line"<sip:*1@127.0.0.1:5060>

    18:55:05.968 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=85749416f2781379 cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire)

    18:55:05.875 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=616fc87495199a3f cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.875 [CM502001]: Source info: From: "Park line"<sip:*0@127.0.0.1:5060>;tag=a322061f; To: "Park line"<sip:*0@127.0.0.1:5060>

    18:55:05.875 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=616fc87495199a3f cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire)

    18:55:05.750 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=8c33c124f01b950d cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.750 [CM502001]: Source info: From: "Unpark line"<sip:*1@127.0.0.1:5060>;tag=2944a60e; To: "Unpark line"<sip:*1@127.0.0.1:5060>

    18:55:05.750 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=8c33c124f01b950d cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire)

    18:55:05.656 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=882df27c48487767 cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.640 [CM502001]: Source info: From: "Park line"<sip:*0@127.0.0.1:5060>;tag=7b771b64; To: "Park line"<sip:*0@127.0.0.1:5060>

    18:55:05.640 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=882df27c48487767 cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire)

    18:55:05.421 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=cc5ef00e453db110 cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.421 [CM502001]: Source info: From: "Unpark line"<sip:*1@127.0.0.1:5060>;tag=c3080862; To: "Unpark line"<sip:*1@127.0.0.1:5060>

    18:55:05.421 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=cc5ef00e453db110 cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire)

    18:55:05.421 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=c73c1d5ddf40b444 cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.406 [CM502001]: Source info: From: "Park line"<sip:*0@127.0.0.1:5060>;tag=b428de54; To: "Park line"<sip:*0@127.0.0.1:5060>

    18:55:05.406 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=c73c1d5ddf40b444 cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire)

    18:55:05.203 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=95320a2fcf704d2f cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.203 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=487c9705f07ca469 cseq=REGISTER contact=*0@127.0.0.1:40000 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    18:55:05.203 [CM502001]: Source info: From: "Unpark line"<sip:*1@127.0.0.1:5060>;tag=f91a4842; To: "Unpark line"<sip:*1@127.0.0.1:5060>

    18:55:05.187 [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 127.0.0.1:5060 tid=95320a2fcf704d2f cseq=REGISTER contact=*1@127.0.0.1:40000 / 2 from(wire)


    Any help would be welcome.

    Once this is solved our next step will be to hook up our Patton 4112 ( 2 x FXO) to the system and use two workstations with 3CX client to test this installed free edition. If everything works, we will definitely go for the full version!!

    Carlos Cairo
    Amsterdam, Netherlands
     
  2. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Hi
    Can you do the following:

    Take a backup of your system (as it is) and restore it immediately.

    Also can you send me from command prompt:

    netstat -ano > result.txt

    Send me results.txt file.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Powdasnow

    Joined:
    Dec 11, 2008
    Messages:
    4
    Likes Received:
    0
    Done!

    Here's the output of the result.txt:

    Active Connections



    Proto Local Address Foreign Address State PID

    TCP 0.0.0.0:1 0.0.0.0:0 LISTENING 2320

    TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 380

    TCP 0.0.0.0:135 0.0.0.0:0 LISTENING 1172

    TCP 0.0.0.0:443 0.0.0.0:0 LISTENING 380

    TCP 0.0.0.0:445 0.0.0.0:0 LISTENING 4

    TCP 0.0.0.0:1035 0.0.0.0:0 LISTENING 380

    TCP 0.0.0.0:3390 0.0.0.0:0 LISTENING 2264

    TCP 0.0.0.0:4400 0.0.0.0:0 LISTENING 5844

    TCP 0.0.0.0:5060 0.0.0.0:0 LISTENING 6000

    TCP 0.0.0.0:5480 0.0.0.0:0 LISTENING 400

    TCP 0.0.0.0:5482 0.0.0.0:0 LISTENING 6000

    TCP 0.0.0.0:5485 0.0.0.0:0 LISTENING 6420

    TCP 0.0.0.0:40000 0.0.0.0:0 LISTENING 6816

    TCP 0.0.0.0:40300 0.0.0.0:0 LISTENING 4688

    TCP 0.0.0.0:40600 0.0.0.0:0 LISTENING 6884

    TCP 127.0.0.1:1044 0.0.0.0:0 LISTENING 2428

    TCP 127.0.0.1:3806 127.0.0.1:3807 ESTABLISHED 2124

    TCP 127.0.0.1:3807 127.0.0.1:3806 ESTABLISHED 2124

    TCP 127.0.0.1:4079 127.0.0.1:4080 ESTABLISHED 1156

    TCP 127.0.0.1:4080 127.0.0.1:4079 ESTABLISHED 1156

    TCP 127.0.0.1:4093 127.0.0.1:5480 ESTABLISHED 6420

    TCP 127.0.0.1:4094 127.0.0.1:5480 ESTABLISHED 6420

    TCP 127.0.0.1:4095 127.0.0.1:5485 ESTABLISHED 5884

    TCP 127.0.0.1:4096 127.0.0.1:5485 ESTABLISHED 7808

    TCP 127.0.0.1:4098 127.0.0.1:5485 ESTABLISHED 6552

    TCP 127.0.0.1:4099 127.0.0.1:5485 ESTABLISHED 6000

    TCP 127.0.0.1:4101 127.0.0.1:5482 ESTABLISHED 6816

    TCP 127.0.0.1:4102 127.0.0.1:5482 ESTABLISHED 6884

    TCP 127.0.0.1:4103 127.0.0.1:5482 ESTABLISHED 4688

    TCP 127.0.0.1:4104 127.0.0.1:5482 ESTABLISHED 7776

    TCP 127.0.0.1:4112 127.0.0.1:5480 ESTABLISHED 5844

    TCP 127.0.0.1:4113 127.0.0.1:4114 ESTABLISHED 5844

    TCP 127.0.0.1:4114 127.0.0.1:4113 ESTABLISHED 5844

    TCP 127.0.0.1:5152 0.0.0.0:0 LISTENING 460

    TCP 127.0.0.1:5152 127.0.0.1:3797 CLOSE_WAIT 460

    TCP 127.0.0.1:5480 0.0.0.0:0 LISTENING 400

    TCP 127.0.0.1:5480 127.0.0.1:4093 ESTABLISHED 400

    TCP 127.0.0.1:5480 127.0.0.1:4094 ESTABLISHED 400

    TCP 127.0.0.1:5480 127.0.0.1:4112 ESTABLISHED 400

    TCP 127.0.0.1:5482 127.0.0.1:4101 ESTABLISHED 6000

    TCP 127.0.0.1:5482 127.0.0.1:4102 ESTABLISHED 6000

    TCP 127.0.0.1:5482 127.0.0.1:4103 ESTABLISHED 6000

    TCP 127.0.0.1:5482 127.0.0.1:4104 ESTABLISHED 6000

    TCP 127.0.0.1:5485 127.0.0.1:4095 ESTABLISHED 6420

    TCP 127.0.0.1:5485 127.0.0.1:4096 ESTABLISHED 6420

    TCP 127.0.0.1:5485 127.0.0.1:4098 ESTABLISHED 6420

    TCP 127.0.0.1:5485 127.0.0.1:4099 ESTABLISHED 6420

    TCP 172.19.3.9:80 172.19.3.8:48109 ESTABLISHED 380

    TCP 172.19.3.9:139 0.0.0.0:0 LISTENING 4

    TCP 172.19.3.9:1046 172.19.3.4:139 ESTABLISHED 4

    TCP 172.19.3.9:3390 172.19.3.8:37478 ESTABLISHED 2264

    TCP 172.19.3.9:3808 207.200.96.138:80 ESTABLISHED 2124

    TCP 172.19.3.9:4135 172.19.3.23:139 TIME_WAIT 0

    TCP 172.19.3.9:5061 0.0.0.0:0 LISTENING 6000

    TCP 172.19.3.9:5090 0.0.0.0:0 LISTENING 2320

    UDP 0.0.0.0:1 *:* 2320

    UDP 0.0.0.0:445 *:* 4

    UDP 0.0.0.0:500 *:* 932

    UDP 0.0.0.0:1053 *:* 3312

    UDP 0.0.0.0:3456 *:* 380

    UDP 0.0.0.0:4500 *:* 932

    UDP 0.0.0.0:40000 *:* 6816

    UDP 0.0.0.0:40300 *:* 4688

    UDP 0.0.0.0:40600 *:* 6884

    UDP 127.0.0.1:123 *:* 1264

    UDP 127.0.0.1:1027 *:* 400

    UDP 127.0.0.1:1085 *:* 1264

    UDP 127.0.0.1:1900 *:* 1400

    UDP 127.0.0.1:5060 *:* 6000

    UDP 172.19.3.9:123 *:* 1264

    UDP 172.19.3.9:137 *:* 4

    UDP 172.19.3.9:138 *:* 4

    UDP 172.19.3.9:1900 *:* 1400

    UDP 172.19.3.9:5060 *:* 6000

    UDP 172.19.3.9:5100 *:* 5844

    UDP 172.19.3.9:14351 *:* 3312

    UDP 172.19.3.9:14958 *:* 3312


    Thank you for your quick response and help!
    Kind regards,

    Carlos Cairo
    Amsterdam, The Netherlands
     
  4. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Can you send me the backup file please? We now know that ports is not the problem.

    Can you make a backup and restore it on the same machine exactly after?
    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Powdasnow

    Joined:
    Dec 11, 2008
    Messages:
    4
    Likes Received:
    0
    I indeed ran a backup and an immediate restore from the same backup, as you requested.
    After that I ran the mentioned 'netstat -ano -> c:\result.txt' command.
    The enclosed attachment '3cx_backup.zip' is the result file from this first system backup.

    Kind regards,

    Carlos Cairo
    Amsterdam, The Netherlands
     

    Attached Files:

  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    it is still not working?

    Can you try and restart the parking orbit service?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Powdasnow

    Joined:
    Dec 11, 2008
    Messages:
    4
    Likes Received:
    0
    No, the same 3 errors appear in the logfile, over and over again.

    If I stop the parking orbit service this is stopped and the logfile stays empty, the 3 errors aren't there anymore.
    As soon as start the parking orbit service the same 3 errors appear in the log again.

    Carlos Cairo
    Amsterdam, The Netherlands
     
  8. OSBroadband

    Joined:
    Dec 12, 2008
    Messages:
    3
    Likes Received:
    0
    I'm having this same exact issue.....any New Updates on the Issue?
     
  9. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Hi OSBroadband

    How did you get this error? Is it after performing a restore? What Operating system did you install 3cx on? Was this a clean installation of 3cx?

    We really need to have The OS you installed 3cx on and also webserver you chose to install on.

    Thanks and regards
    Nicky
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. itspatrick

    Joined:
    Dec 5, 2008
    Messages:
    1
    Likes Received:
    0
    Hi!

    i have same problem. Windows XP SP3 fresh install. 3CX version 7.0.3406.0.

    Patrick

    paris, France
     
  11. OSBroadband

    Joined:
    Dec 12, 2008
    Messages:
    3
    Likes Received:
    0
    Hello Nicky,

    Unknown how I'm getting this error, this is a clean install of the latest version of 3CX ver 7 on a Windows XP SP3 workstation / IIS.
     
  12. Paulh

    Joined:
    Apr 16, 2008
    Messages:
    27
    Likes Received:
    0
    Nicky,

    I get it on SBS 2008 (as previously emailed). new/clean install.

    Paul
     
  13. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    hi itspatrick :
    Although it seems that many people are having this problem in your case Patrick you need to install the latest version of 3cx phonesystem. This will surely minimize the possibility of reproducing this error. We still do not know what the cause of this problem is because the final version of 3cx has a fix for this. You mentionned in your post that you are using version 3406. Please uninstall this version, run the installation checker tool and install the latest from here:

    http://www.3cx.com/phone-system/download-links/ This is version 4249 (the latest)

    Paul - did you upgrade to the latest final version please? This is very important. If you did so can you do the following and tell us if this procedure fixes this or not:

    Take a backup of your current system. Exactly after you do this restore it. Give us an update with the result. If this fails we really need to have a look at that backup file please. Place it somewhere and we will download is ASAP.

    OSbroadband - Please specify the version 7 you are using. Make sure it is the latest. Do the same thing suggested to Paul - Backup and restore. We will also need to see the backup file. It could be that in some cases and on some machines the fix we made does not work 100% but this is very strange. We need to see those backup files. To make them smaller, you can omit backing up voicemails and recordings.

    Carlos Cairo - I downloaded the backup file and tried it out. Thanks for this. I performed a restore and the parking orbits registered for me immediately. This means that the Parking orbit extensions were created in the database. (Because this is why you are getting spamming from the parking orbit service. The extensions are not created and authentication is failing as there is nothing to successfully authenticate with.) Now you also mentioned that you tried this restore already - this makes it even more strange. I will check further and let you know.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Everyone having this problem: Can you send us

    1) a backup of your PBX settings and
    2) The wizard logs from here
    C:\Program Files (x86)\3CX PhoneSystem\Bin
    3cxwizard.txt

    Send them to nb@3cx.com directly (if the backup file is too big you can put somewhere publicly available and I will download it no problem.

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Hi

    We are investigating this full blast.

    A fix that works for sure is if you take a backup of the current system and restore it immediately after. USING THE LATEST VERSION v7.4249..

    Then the spamming should stop because the restore will automatically add the parking extensions to the database.

    Just run a backup and restore it immediately after.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    OK Guys - there is an easier workaround than taking a backup and restoring it!!

    Do the following

    Go to Advanced in the management console
    Click on the Dial Codes Tab
    Change the Parking code to something else example *7 (something that does not exist as a dial code.)
    Change the Pickup a Parked Call to something else example *8 (also a unique dial code)
    Click Apply and OK.

    The Spamming will stop and the new dial codes will register using *7 and *8.

    After this go back to the dial codes page and revert *7 and *8 to what they originally were i.e.*0 and *1
    Again the previous dial codes (*7 and *8) will unregister and *0 and *1 will register with success.

    Let us know on the progress you make on this. Ideally at this point it would be much appreciated if you send me the 3cxwizard.txt file just the same. The backups are not required any more.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. koenvandaalen

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    I use the free "trial" version of 3cx and it doesn't seem possible to change the dial codes in this version. The are just grayed-out. The backing up and restoring workaround doesn't work either.
    It however doesn't seem to affect the functionality as the phone system does its job. The spamming of the logging is however quite cumbersome when trying to determine why a certain (connection) problem does occure.
    Are you preparing a fix soon?

    Thanks for this great new release. It seems, apart from this bug, to be a big improvement over the version 6.1
     
  18. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,110
    Likes Received:
    143
    Hi

    Activate the PBX using a demo key AII8-CRF7-JYDX-8N3T

    Change the dial codes and restart.

    Then change them again to what they were before. Confirm that this fixes the problem.

    Can you send us the Wizard.txt file? It is found in the Bin directory
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. koenvandaalen

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    I found the following file in the bin directory: 3cxwizardlog.txt. Is this the file you are interested in?

    Contents:

    18-12-2008 18:26 Checking database connectivity.
    18-12-2008 18:26 Check failed: Failed to establish a connection to 'localhost'.
    18-12-2008 18:26 Checking database connectivity.
    18-12-2008 18:26 Checking for previous database existence.
    18-12-2008 18:26 Check failed: FATAL: 3D000: database "phonesystem" does not exist
    18-12-2008 18:26 Language selection passed.
    18-12-2008 18:26 Select Extension number digits passed.
    18-12-2008 18:27 Create SIP Domain.
    18-12-2008 18:28 SMTP/Email passed at:18-12-2008 18:28:38
    18-12-2008 18:29 Validate Extension Record passed OK
    18-12-2008 18:29 Connecting to database 'template1'.
    18-12-2008 18:29 Database created successfully.
    18-12-2008 18:29 Create schema for database 'phonesystem'.
    18-12-2008 18:29 Database 'phonesystem' was created successfully.
    18-12-2008 18:29 Connecting to ObjectModel
    18-12-2008 18:29 Creating extension '100'
    18-12-2008 18:29 Found phone model in xml
    18-12-2008 18:29 DBCreator.CreateExtensions exception: Malformed MAC address
     
  20. koenvandaalen

    Joined:
    Dec 18, 2008
    Messages:
    3
    Likes Received:
    0
    The errors went away after activating the demo licence and changing the 2 dialcodes as mentioned above.
    Thanks for your help.
     
Thread Status:
Not open for further replies.