3102 Ringing Wrong Place

Discussion in '3CX Phone System - General' started by Anonymous, Aug 20, 2008.

Thread Status:
Not open for further replies.
  1. Anonymous

    Anonymous Guest

    I've got 3CX (currently free version to test it out and work out some of the kinks) 6.0.806. I've got a couple of Linksys SPA962 phones. Each has two occurrances of the phone extension (711 on one and 712 on the other) and then a single occurrance of a second extension (731 and 732, respectively).

    I've got two SIP trunks from InPhonex.

    I've got four SPA3102 devices connected. One goes to a business POTS line. Two go to Vonage lines via the Vonage adapter (basically, POTS). The fourth goes to a home POTS line.

    I've got a couple of different ring groups configured, one that rings the "main" extensions and another that rings the "secondary" extensions. I've also got an auto-attendant chain configured to do various things (answer and give the greeting, allow hitting a key to get right to an extension, ring the "main" extension group, etc.). All lines are set to go to either the day or night auto-attendant except the fourth SPA3102. Instead, it is set to go to the hunt group that rings the "secondary" extensions.

    So in theory, if someone calls on the Vonage lines, the InPhonex SIP trunks, or the business POTS line, they'll get the office auto-attendant. If someone calls on the home POTS line, it would ring on the secondary extensions on all phones and that's about it.

    However, for some reason, if I plug in the home POTS line to the proper SPA3102 and try to call on it, it goes straight to the office auto-attendant. It is NOT configured to go there within the PSTN gateway configuration in 3CX but it is anyway. I've rebooted the 3CX machine to no avail.

    If I unplug it, then it obviously just keeps ringing when I call that number from outside.

    This is driving me nuts! Anyone got any ideas what might be causing the problem?
     
  2. Anonymous

    Anonymous Guest

    I managed to answer my own question - which I'll post here in case anyone else comes across this.

    It turns out that I used the same dialing plan for all four of the SPA3102's: "(S0<:10002>)" which evidently means that all four of them were showing themselves as being from extension 10002. When I changed that last one to 10005, it worked just fine. (except I still don't get the caller ID coming through but that's another thread)
     
  3. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    Hello,

    set PSTN Answer Delay to 4
     
  4. Anonymous

    Anonymous Guest

    I'm assuming you're referring to the problem of not getting caller ID (which is in another thread). Someone (in the other thread) suggested changing the answer delay on the 3102 to 5... which I did. It didn't make a difference. I'm not sure if it is simply that it isn't able to get the caller ID (and thus having nothing to pass on) or whether (more likely) there's some configuration someplace (perhaps in 3CX) that makes it take that caller ID information through the auto-attendant sessions and then use that when it forwards the call to the ring group.

    Actually, I have one POTS line that is set to do nothing but ring at a ring group - and it shows the caller ID as being the 3102's name. I had tried setting the answer delay to 5 in the 3102 but it didn't help.
     
  5. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    remove any data at PSTN CID Name Prefix:

    and check in regional tab for :

    Caller ID Method:
    Caller ID FSK Standard:

    I'm always advice to reset to factory set and reconfig again
    because SPA3102 has a lot off settings
     
  6. Anonymous

    Anonymous Guest

    I doubt a factory reset would help because these were all brand new and should be straight from the factory already. Only things changed were those few fields specified in the 3CX config template.

    I'm going to be heading out of town on a vacation for 3 weeks but I'll check those settings when I get back (or if I manage to get a few extra minutes sometime tonight or tomorrow before I leave).

    Thanks.
     
  7. galal202

    galal202 New Member

    Joined:
    Jun 23, 2008
    Messages:
    235
    Likes Received:
    0
    Hello,
    you have to update your firmware
    also 3cx does not need much configuration from factory set so it's the best way to be sure that all settings are
     
Thread Status:
Not open for further replies.