3CX 1.3.4 no sound unless i use 3CX tunnel

Discussion in 'Android' started by KlasRudian, May 25, 2012.

Thread Status:
Not open for further replies.
  1. KlasRudian

    Joined:
    May 25, 2012
    Messages:
    2
    Likes Received:
    0
    Hi,

    Device Info
    -------------------------------------------------------
    Phone Model: [Samsung Galaxy Nexus]
    Firmware Version: [4.0]

    Issue Info
    -------------------------------------------------------
    Handset: [Phone]
    Contacts: [Local|Direct call to number]
    Connection: [WiFi|3G]
    Server: [External]

    As stated in the topic, cant get any sound if i dont use the 3CX tunnel to the server.
    But if i use the tunnel i cant get it to recive calls from its "public" phone number (The public phonenumber provided by the voip provider).

    So in short, if i dont use the tunnel i have no sound, cant hear anything if i call 999 and so on, and if i call another extension/phonenumber they cant hear me either, BUT the "public" phonenumber does work and it calls in the android client.

    If i use the tunnel sound works, but the public phonenumber doesnt work, internal extension can call me thou.

    Oooh yeah i can always call internal extension and "public" phonenumbers, its only the sound or INCOMING calls to my "public" phonenumber that is the issue.

    Anyone got any bright ideas on how to sort this issue?

    /Kristoffer


    Edit:
    Can add that i just tried it with an iPhone, and it has exactly the same issue
     
  2. KlasRudian

    Joined:
    May 25, 2012
    Messages:
    2
    Likes Received:
    0
    Just upgraded to 2.0.0 and it all works aslong as i use the 3CX tunnel

    Cant answer for the iPhone thou, only tried on my Galaxy Nexus

    /Kristoffer
     
  3. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,218
    Likes Received:
    89
    if you only have audio with tunnel there are two reasons:

    1) You have not set the NAT on the Wifi site and pbx site correctly
    2) on 3G the telco blocks VoIP
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.