3CX and Cyberdata VoIP Ceiling Speaker/Intercom

Discussion in '3CX Phone System - General' started by eihli, Mar 31, 2011.

Thread Status:
Not open for further replies.
  1. eihli

    Joined:
    Jan 3, 2011
    Messages:
    16
    Likes Received:
    0
    We have a 3CX phone server at the main office and we have some phones and CyberData VoIP equipment at a remote office.

    We have 3com routers doing port forwarding at each office. At the remote office, each VoIP device has its own static IP and its own local SIP port.

    Everything works fine except the CyberData equipment.

    When I place a call to the Intercom, 3CX generates this log message:
    10:35:43.783 [CM503004]: Call(1587): Route 1: Ext:Ext.199@[Dev:sip:199@<remote office public ip>:5063;line=b0e481044ef2646]
    It is making a route to the WAN IP of the remote site with a port forwarded to the remote device and the call is connected but only has one-way audio. The phone can hear the someone at the intercom, but the intercom cannot hear someone at the phone.

    But when I place a call to the Ceiling Speaker, 3CX generates this log message:
    10:35:01.241 [CM503004]: Call(1585): Route 1: Ext:Ext.210@[Dev:sip:210@<remote device LAN address:5066]
    It is making a route to the LAN IP of the remote device and the call is never connected.

    The documentation at http://www.cyberdata.net/products/voip/digitalanalog/ceilingspkr/docs.html has a picture of the SIP config page. I am guessing it has something to do with the CyberData equipment not having an option for a STUN server? But if STUN is the issue, and neither device supports STUN, then why does one device have the remote office's public IP translated and the other device get stuck with the private LAN IP?

    I have a support ticket open with Cyberdata on this also but I was wondering if someone here might be able to shed some light on what would cause this.

    Thanks,
    Eric Ihli
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Good question, if neither device supports STUN. It is pretty much a given that you have to have a STUN option to get a remote phone working properly (two way audio), unless..you are using a VPN connection, or, you use the 3CX proxy server at the remote end. I have seen audio issues crop up (rarely, mind you), even with STUN enabled devices (multiple devices at one remote location), because of the particular router, at that location, and how it handled the voice packets.
     
Thread Status:
Not open for further replies.