Solved 3CX and Grandstream

Discussion in '3CX Phone System - General' started by Fabione, Mar 26, 2018.

Thread Status:
Not open for further replies.
  1. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    I have a 3CX Professional 15.5.9348.3 and I have 25 Grandstream Phones, GXP2135 and GXP2170.

    Every day some random Exetension got unregistered and the only way to got registered again is with a reboot of the phone ...

    The GS phones have 1.0.9.58 firmware and are correctly provisioned on 3cx.

    Any suggestion ?
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,218
    Likes Received:
    174
    Hi Fabione,

    Firstly firmware version of the phone ? is it running a 3CX "supported" version ?

    Also when it is in the un-registered state it would be worth running a PCAP from the phone itself to see whether:

    a) The phone is actually sending a registration request to 3CX.
    b) 3CX is responding to that request.

    This would give a better indication to where the issue may lie (Phone(s) or PBX).
     
  3. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    Hello, I'm running supported version firmware, downloaded from 3CX site.

    I'll wait for the next extension that will go offline to PCAP.
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,311
    Likes Received:
    249
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    Thank you but my web GUI working and I can reboot phone and it will go to register again ... I tested to factory reset but no way to resolve ...

    SIP Server/Call Manager ID: 4101
    Extension 102 is unregistered, removed contact: sip:102@192.168.0.202:5060

    And a lot like this every day with multiple extension.

    Thanx anyway !
     
  6. Doctor Rob

    Joined:
    Mar 28, 2018
    Messages:
    11
    Likes Received:
    0
    Just a thought but if all the phones are in the same place and having similar issues it could easily be that your switch they are all connected to is having intermediate issues.. (I had that issue with one switch and it turned out to be a bad cable) it would cause intermediate power loss being everything I pretty much use uses the POE. though in my case it would FULLY reboot like you unplugged and plugged it back in.
     
  7. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    Now an extension is offline, pcap is there.

    Any Idea ?
     

    Attached Files:

  8. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    522
    Likes Received:
    12
    Hi,
    in your pcap there is no any SIP messages, so I assume that the phone is not sending REGISTAR messages.
    You said that FW on your phone is 1.0.9.58, but on 3cx pages there is a newer version, 1.0.9.68.
    Can you try upgrade your phones and see is the issue still persist?

    Are you using default template, did you change any of this parameter:

    <!-- # Register Expiration (in minutes. default 1 hour, max 45 days) -->
    <P32>2</P32>

    <!-- Reregister Before Expiration (in seconds). Default is 0 second -->
    <!-- Number: 0 - 64800 -->
    <!-- Mandatory -->
    <P2330>0</P2330>

    I am not sure is this is correct in original template, it says "in minutes" for P32 so P32 is 2 minutes?
    And P2330 is in seconds, 0 seconds.

    I would use for P32 one hour and for P2330 half of that time (30 minutes)
     
  9. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    Now I upgraded any phone to 1.0.9.68 and set P32 to 60 (Minutes) and P2330 to 1800 (Seconds).

    In original Template P32 was 2 (Minutes) and P2330 was 0 (Seconds).

    Thank you, I'll write you if I will have other disconnession.
     
    #9 Fabione, Apr 2, 2018
    Last edited: Apr 2, 2018
  10. Fabione

    Joined:
    Feb 25, 2017
    Messages:
    14
    Likes Received:
    1
    Anythinghs is working good with the new setting for P32 and P2330.

    Thank you very much !!
     
  11. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Glad to see the issue has been resolved and thank you for updating the thread.
     
Thread Status:
Not open for further replies.