3CX and musimi, no sound on incoming calls

Discussion in '3CX Phone System - General' started by Dark One, Dec 11, 2007.

  1. Dark One

    Joined:
    Dec 11, 2007
    Messages:
    9
    Likes Received:
    0
    Hi

    I have a setup with 3CX and musimi VOIP provider.
    I have opened UDP for stun, sip and rtp ports according to my PBX setup.
    Ringing out makes no problem and all works, so does internal calls.
    But when i cal from my cell to the sip number, i can make connection but there are no sound throug the line.
    I obviously have made some error :)
    Any ideas?
     
  2. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Witch ports (how many) have you opened?

    List of default ports used by the 3cx phonesystem:
    5060 (stanard sip port) TCP/UDP
    5061 (secondary sip port) TCP/UDP
    5480 (portgre) (only on local machine)
    5481 (apache) (only on local machine)
    5482 (media server) (only on local machine)
    3478 (STUN Server) TCP/UDP
    7000-7500 (Default port for internall calls) (only on local machine)
    9000 - 9003 (ports for external calls through VOIP Gateway) UDP
    10000-20000 (RTP ports) (Used if no stun available for audio)
     
  3. pbnet

    Joined:
    Oct 25, 2007
    Messages:
    12
    Likes Received:
    0
    Re:

    Have the same problem. No ringing tone/music on hold when I dial inside numbers. No problem for outbound calls.
     
  4. silentfun

    silentfun Member

    Joined:
    Dec 11, 2006
    Messages:
    364
    Likes Received:
    0
    please give us the call related part of the incomming call and a example for a outgoing "good" call from your server log.

    perhaps we can see what happens.

    Andy
     
  5. Dark One

    Joined:
    Dec 11, 2007
    Messages:
    9
    Likes Received:
    0
    I have opened following ports in ISA

    3874 tcp -outbound
    3874 udp send/rec
    5060 - 5062 tcp -outbound
    5060 - 39999 udp send/rec

    that should cover the ports quite well

    Allow non-sequental RTP port is set to check

    i still can't figure it out.

    What log files do i need to check ?
     
  6. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    This should be 3478 for STUN, not 3874.
     
  7. Dark One

    Joined:
    Dec 11, 2007
    Messages:
    9
    Likes Received:
    0
    well unfortunately the fault was in my post, not on my firewall :(
    So i have actually opened 3478 in ISA both tcp and udp
    And i get no stun errors.
    Maybe my provider does not use stun ?
    What options do i have if no stun ?
     
  8. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    If your provider does not have stun you can use 3cx's.

    stun.3cx.com
    stun1.3cx.com

    It does not make a difference as long as you use the same stun in all your phones and PBX.
     

Share This Page