3CX and Zadarma VoIP Provider

Discussion in '3CX Phone System - General' started by voiper, Feb 11, 2015.

Thread Status:
Not open for further replies.
  1. voiper

    Joined:
    Mar 24, 2008
    Messages:
    29
    Likes Received:
    0
    Dear Fellows,

    3CX blocks by default user agent "sipsak" which is used by several providers, e.g. from the affordable and serious zadarma.com. Now I removed the blocking entry for "sipsak" in 'SEC_IGNORE_USER_AGENT' field in Settings->Advanced->custom parameters. So far so good, Zadarma is working now.

    But I don't want to open a security hole and I'm asking myself how can I enable Zadarma without general removing the often malicious agent "sipsak" in 'SEC_IGNORE_USER_AGENT'. Is there another solution available?

    Thanks for any hints.

    Best regards
     
  2. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,415
    Likes Received:
    276
    Do you have any users connecting remotely?
    Are they all in offices or do you use iOS/Android softphone?

    If you do not have users with iOS/Android or road warriors, you can open up 3cx communication only to the provider(and remote offices) on your firewall and block other inbound traffic. You can also add them to the whitelist for good measure in 3cx.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. voiper

    Joined:
    Mar 24, 2008
    Messages:
    29
    Likes Received:
    0
    Hi Craig,

    thanks for your response and useful hints.

    Unfortunately there are road warriors and smartphone users connected to 3CX.

    Is ist possible to add Zadarma to a whitelist and keep 'SEC_IGNORE_USER_AGENT' on default settings?

    Best regards
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,415
    Likes Received:
    276
    Unfortunately, I do not know if SEC_IGNORE_USER_AGENT takes priority over the Whitelist or not.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.