3CX Assistant and desk phone**Discussion

Discussion in '3CX Phone System - General' started by discovery1, Jul 9, 2010.

Thread Status:
Not open for further replies.
  1. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    I have the version 9 3CX Assistant installed without the 3CX phone component installed.

    I am not able to select the "Call via PBX" option in the 3CX assistant dialing preferences. It is set to "Make call using 3CX phone" which is greyed out. Is this normal?

    I want the 3CX assistant to launch the call and ring the Snom 300 on the desk next to me but this does not seem to be possible at the moment.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Re: 3CX Assistant and desk phone

    No it is not normal. In any case - the make call using 3CX Phone should be grayed out not make call via pbx.

    What did you do exactly? Did you have a v8 installation WITH phone and installed over without phone by any chance?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Re: 3CX Assistant and desk phone

    Yes we think we replicated this -

    However it still lets you click on the radio buitton to make calls via pbx. Can you confirm?
    This leaves it just to be a visual issue. Not critical.
    We replicated it like this - Version 8 ASSISTANT+phone installed.
    Install Over with version 9 but we removed the phone. leaving assistant without phone installed.

    End result

    Radio button is on phone which is grayed out.

    You just need to click on make calls via pbx. You will not be able to click on the make call via 3CXPhone again. Good.
    Let us know
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Re: 3CX Assistant and desk phone

    Hi Nicky

    The upgrade path was from a version 8 backup to current version 9 RC using the normal backup and restore method.
    Prior to the install of the 3CX assistant i had the version 8 3CX phone but this was uninstalled before installing the version 9 Assistant.

    The current setup will allow you to select the "calls via PBX" but when you initiate a call from within outlook the desk phone does not ring and the Assistant shows a call in progress but the desk phone never rings (at least not after 20+ seconds)

    Checking the settings in the Assistant after selecting "Call via PBX shows the setting back to "Make call using 3CX phone" which is greyed out.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Re: 3CX Assistant and desk phone

    OK - just done complete uninstall and cleaned all folders and registry entries for 3CX assistant settings.

    Reinstall of RC and in-place upgrade.

    This issue STILL remains. I also have two options to call a contact within outlook "Call Contact" and "Call contact using 3CX > Call business"

    The "Call contact" option pops up the Standard New Call box where i can click the "Start Call" button which will ring the Snom phone on the desk. This is not the most elegant solution as the Flexor software that used to come with the Snom phones would just place the call and the desk phone would start ringing without the extra step.

    Using the "Call contact using 3CX > Call business" ALWAYS uses the 3CX soft phone regardless of the setting chosen in the 3CX assistant preferences. Uninstalling the 3CX soft phone component causes an error "The 3CX soft phone is not installed"

    What i would like from the 3CX assistant Outlook plug-in is the same functionality as we used to have with the Flexor software. Right clicking a contact in outlook and choosing "Call contact using 3CX > Call business" should start the desk phone ringing straight away using the makecall feature.

    Is this difficult to achieve?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Re: 3CX Assistant and desk phone

    be careful because i think you are provisioning your extension all the time with integration set to on. This is why call contact business goes to the phone.

    Those setting in the CA work - Dialling - Make call via pbx - will make the call via 3CX and you can choose whether to have intercom on or off.
    Make call using 3CXPhone makes call using the 3CXPhone with integration on.

    So the best thing to do is to switch off provisioning on the assistant so your settings are not overwritten.

    Call contact makes a call using tapi. Dialing options and confirm that the line used is 3CXTapi Service Provider. Make sure that you do not have multiple entries there. The correct entry should be the following 3CX TAPI Service Provider

    Call contact with 3CX -> Business will use make call. And if you have make call via pbx with intercom on, you will get what you want because you will not need to pick up your phone.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Re: 3CX Assistant and desk phone **SOLUTION PROVIDED**

    Hi Nicky

    Thanks for the extra detail. You are correct that the auto-provisioning was on and this is the cause of the settings reverting back.

    Using the "Call contact using 3CX > Call business after removing the auto-provision from the config caused the desk phone to ring immediately - perfect!

    For an enterprise where you want to always auto-configure the 3CX assistant settings can you force the settings from the 3CX server side to always use the desk phone? Can this be a template that you or we can add somewhere?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    Basically you need to force users to use the deskphone correct.
    So in the users extension you should not check the checkbox Provision 3CXAssistant with 3CXPhone integration because this will check the option in the assistant to use the phone in the dialing options.

    (edit extension / 3CXPhone/Assistant provisionin / last option
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Thanks Nicky, but from an enterprise level that's not really an option. If we untick the autoprovision then the users need to provide details which allows for errors.
    We need to be able to autoprovision the 3CX assistant with no user input but we want to be able to change the settings.

    Are there any registry entries or ini files that we can modify using Group policy or group policy preferences?
    That way we can fully automate the deployment and configuration.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,111
    Likes Received:
    143
    No you asked me how can users use only their deskphone. I did not tell you to disable provisioning. What that checkbox does is it provisions the assistant to use the deskphone. THis implies that you dont want the 3CX Phone correct? How many phones are you going to have?
    Now also you can paste the same link in the phone if you want to use the phone also. Users need to create a profile, paste the same link they receive in the welcome email and the phone will provision.
    Hope I understood correctly this time. Thanks for your feedback.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.