3CX behind Cisco 827H ADSL router

Discussion in '3CX Phone System - General' started by Fallout, Mar 12, 2008.

Thread Status:
Not open for further replies.
  1. Fallout

    Joined:
    Oct 10, 2006
    Messages:
    12
    Likes Received:
    0
    I have successfully set up a 827H router to use on my ADSL account.

    I have working port forwards for FTP,Bittorrent,HTTP and Mail.

    What I am having trouble with is my 3CX pbx.
    I have traversed NAT by forwarding all ports relevent to my pbx but I
    still can not register the 2 SIP accounts I am using.3CX works just fine with my Draytek router but it supports UPnP which of course Cisco doesn't.

    I have searched everywhere for a solution and have not found one.
    The only documentation I found on this for 3CX is in the faqs of this Site but is for the Web Setup path not CLI.
    I am thinking I may have to add a ACL for SIP but I am not sure.

    If any of you are using 3CX behind a Cisco Router could you look at my config below to see where I have gone wrong.
    I also have done a #show version to allow you to check my version of IOS.

    gateway1#show version
    Cisco Internetwork Operating System Software
    IOS (tm) C820 Software (C820-OY6-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
    Synched to technology version 12.2(5.4)T
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 11-Apr-02 16:24 by ealyon
    Image text-base: 0x80013170, data-base: 0x806A92CC

    ROM: System Bootstrap, Version 12.2(4r)XM2, RELEASE SOFTWARE (fc1)
    ROM: C820 Software (C820-OY6-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

    gateway1 uptime is 44 minutes
    System returned to ROM by power-on
    System image file is "flash:c820-oy6-mz.122-4.YA2.bin"

    CISCO C827H (MPC855T) processor (revision 0x401) with 31744K/1024K bytes of memory.
    Processor board ID FOC06240PUX (3980510627), with hardware revision 0000
    CPU rev number 5
    Bridging software.
    1 Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102

    gateway1#show running-conf
    Building configuration...

    Current configuration : 2997 bytes
    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname gateway1
    !
    enable secret 5 $1$jQMx$jJeZ1iATM5tfakR5pXg7u/
    enable password ********
    !
    ip subnet-zero
    ip name-server 203.12.160.36
    !
    vpdn enable
    !
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    ip mtu adjust
    !
    !
    bridge irb
    !
    !
    interface Ethernet0
    description LAN
    ip address 192.168.10.1 255.255.255.0
    ip nat inside
    no keepalive
    no cdp enable
    hold-queue 32 in
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description WAN
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface Dialer0
    no ip address
    no cdp enable
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp chap hostname **********@nsw.exetel.com.au
    ppp chap password 7 08354D570B0B0C03065A54547C
    !
    ip nat inside source list 101 interface Dialer1 overload
    ip nat inside source static tcp 192.168.10.10 5061 interface Dialer1 5061
    ip nat inside source static tcp 192.168.10.10 21 interface Dialer1 21
    ip nat inside source static tcp 192.168.10.10 22 interface Dialer1 22
    ip nat inside source static tcp 192.168.10.2 49152 interface Dialer1 49152
    ip nat inside source static tcp 192.168.10.10 25 interface Dialer1 25
    ip nat inside source static tcp 192.168.10.10 110 interface Dialer1 110
    ip nat inside source static tcp 192.168.10.10 6080 interface Dialer1 6080
    ip nat inside source static tcp 192.168.10.10 5060 interface Dialer1 5060
    ip nat inside source static tcp 192.168.10.10 9000 interface Dialer1 9000
    ip nat inside source static tcp 192.168.10.10 9001 interface Dialer1 9001
    ip nat inside source static tcp 192.168.10.10 9002 interface Dialer1 9002
    ip nat inside source static tcp 192.168.10.10 9003 interface Dialer1 9003
    ip nat inside source static udp 192.168.10.10 9003 interface Dialer1 9003
    ip nat inside source static udp 192.168.10.10 9002 interface Dialer1 9002
    ip nat inside source static udp 192.168.10.10 9001 interface Dialer1 9001
    ip nat inside source static udp 192.168.10.10 9000 interface Dialer1 9000
    ip nat inside source static udp 192.168.10.10 5060 interface Dialer1 5060
    ip nat inside source static udp 192.168.10.10 5004 interface Dialer1 5004
    ip nat inside source static udp 192.168.10.10 5005 interface Dialer1 5005
    ip nat inside source static udp 192.168.10.10 3478 interface Dialer1 3478
    ip nat inside source static udp 192.168.10.10 5482 interface Dialer1 5482
    ip nat inside source static udp 192.168.10.10 5061 interface Dialer1 5061
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    !
    !
    access-list 101 permit ip 192.168.10.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    snmp-server community y RO
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    exec-timeout 0 0
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    password ********
    login
    length 0
    !
    scheduler max-task-time 5000
    end




    Cheers,

    Fallout
     
Thread Status:
Not open for further replies.