3CX Client Empty For External User

Discussion in 'Windows' started by George C, Sep 25, 2017.

Thread Status:
Not open for further replies.
  1. George C

    Joined:
    Jul 24, 2017
    Messages:
    16
    Likes Received:
    3
    Hello,

    We have an external user whose 3CX comes up as empty. This issue began this morning when the user logged onto her computer. I have checked her settings under "Configure Account" and everything is correct. We have made sure that the tunnel is enabled in her softphone as well.

    I did notice on our 3cx server that the SIP register request was blocked on her IP due to WAN requests being blocked. I disabled that option on her extension but the issue has continued. I uninstalled 3cx, restarted the computer with her, reinstalled and re-configured via a new welcome email, without any luck. We also tried with her anti-virus/firewall disabled, and I reset the 3cx password in her client as well just in case.

    With the block WAN requests being disabled, I no longer see any activity for her extension in the error logs or in the activity logs. Any ideas on what may be causing this and what we can do to correct it?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    Hello @George C

    Do you get an error on the client when it's trying to connect? Do you see the client connected under the phone tab in the management console? What if you send a welcome email of a different extension onto that machine, does that work?
     
  3. George C

    Joined:
    Jul 24, 2017
    Messages:
    16
    Likes Received:
    3
    Thank you for the reply! The user's softphone appears to be trying to register constantly. Once I was home yesterday evening, I noticed the same issue with the 3CX app on my Android phone. I have been notified since that other remote users are now experiencing the same problem. As for the phone tab, I do not see the user's softphone listed. I will try sending the welcome email for a different extension and test that way.

    Thanks!
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    Since the issue is present with other extensions/clients as well i would suggest you make sure that the firewall checker passes all tests successfully. There might be an issue with port 5090. It there is any firewall or antivirus software enables on the server please make sure that these are disabled. Check the blacklist once again in case something else git blacklisted
     
Thread Status:
Not open for further replies.