3CX Debian 8.8 + 3CX PBX 15.5 - Exchange contact sync not working

Discussion in '3CX Phone System - General' started by SECOIT GmbH, Jul 5, 2017.

Thread Status:
Not open for further replies.
  1. SECOIT GmbH

    Joined:
    Apr 3, 2017
    Messages:
    66
    Likes Received:
    19
    I'm struggling with Exchange Contact Sync.

    First of all I created an Exchange impersonated user account as per manual.
    According to this thread I used the "Office 365" button to contact my Exchange 2013.
    And according to this thread basic authentication needs to be enabled to get rid of the http 401 errors which also worked. (@3cx team - please add this to the manuals)

    And now: In the IIS logs on des Exchange CAS I see the PBX contacting the server, successful authentication to the /EWS directory and... that's it. Nothing else is happening.
    Is there any place on the PBX where I can find sync log files so I can trace what the system is doing?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Lev

    Lev New Member

    Joined:
    Sep 19, 2015
    Messages:
    119
    Likes Received:
    17
    You should find your logfile in /var/lib/3cxpbx/Instance1/Data/Logs/3cxSystemService.log
     
  3. SECOIT GmbH

    Joined:
    Apr 3, 2017
    Messages:
    66
    Likes Received:
    19
    Thank you, Lev!
    I was aware of the 3cxSystemService.log but it didn't show anything related to sync. My PBX seemed to be ignoring the Exchange settings completely. So I contacted support and this seems to be an error that can happen in rare circumstances and they provided a workaround by renaming a .DLL file.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.