3cx fax server not working

Discussion in 'Windows' started by dazred, Nov 2, 2010.

Thread Status:
Not open for further replies.
  1. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    Recently upgraded to 3cx phone system v9 sp3-and now im not able to get fax extensions to recieve faxes.


    Previously In Version 8 I configured a few DID's to be dedicated to fax. It worked well. The 3CX Fax server received the fax,
    converted them to PDF and then emailed the fax to the configured email address I had set up. When I upgraded to version 9 sp3 and restored the backup files we stopped recieving faxes

    when I test the fax DID via mobile phone -the call drops, when i test via an extenal fax machine the fax gets no answer
    system log from test call from mobile:

    11:00:45.677 Currently active calls - 5: [821,826,830,831,832]
    11:00:45.459 [CM503008]: Call(833): Call is terminated
    11:00:45.349 Remote SDP is set for legC:833.2
    11:00:43.927 Session 70425 of leg C:833.1 is confirmed
    11:00:43.834 [CM503007]: Call(833): Device joined: sip:8888@10.***.**.**:5100;user=phone
    11:00:43.834 [CM503007]: Call(833): Device joined: sip:10.***.*.*:5060
    11:00:43.834 [MS210007] C:833.1:Answer provided. Connection(by pass mode): 10.***.**.**:10002(10003)
    11:00:43.834 [MS210001] C:833.2:Answer received. RTP connection[unsecure]: 10.***.**.**:10002(10003)
    11:00:43.818 Remote SDP is set for legC:833.2
    11:00:43.818 [CM503002]: Call(833): Alerting sip:8888@10.***.**.**:5100;user=phone
    11:00:43.771 [CM503025]: Call(833): Calling @[Dev:sip:8888@10.***.**.**:5100;user=phone]
    11:00:43.771 [MS210006] C:833.2:Offer provided. Connection(by pass mode): 10.***.*.**:32300(32301)
    11:00:43.724 [CM503004]: Call(833): Route 1: @[Dev:sip:8888@10.***.**.**:5100;user=phone]
    11:00:43.724 [CM503010]: Making route(s) to <sip:4***@10.***.**.**:5060;user=fax>
    11:00:43.724 [MS210000] C:833.1:Offer received. RTP connection: 10.***.*.**:32300(32301)
    11:00:43.724 Remote SDP is set for legC:833.1
    11:00:43.724 [CM505003]: Provider:[Wavecrest1] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:10.***.**.**:5060]
    11:00:43.724 [CM503001]: Call(833): Incoming call from 7********@(Ln.10001@Wavecrest1) to <sip:4001@10.***.**.**:5060;user=fax>
    11:00:43.709 [CM503012]: Inbound any hours rule (MAIN FAX) for 10001 forwards to Fax:4****
    11:00:43.709 Looking for inbound target: called=44207*******; caller=7*********
    11:00:43.709 [CM500002]: Info on incoming INVITE:
    INVITE sip:44207********@10.***.**.** SIP/2.0
    Via: SIP/2.0/UDP 10.***.*.*:5060;branch=z9hG4bK281938d33ef0c0f9ecb0e88756a62278
    Max-Forwards: 67
    Contact: <sip:7*********@10.***.*.*:5060>
    To: "44207*******"<sip:44********@10.***.*.*>
    From: "7*********"<sip:7*********@10.***.*.*>;tag=3497684443-699185
    Call-ID: 212113-3497684443-699179@UK*-***-**-0.mydomain.com
    CSeq: 1 INVITE
    Expires: 300
    Session-Expires: 3700;refresher=uac
    Allow: INVITE, BYE, OPTIONS, CANCEL, ACK, REGISTER, NOTIFY, INFO, REFER, SUBSCRIBE, PRACK, UPDATE
    Call-Info: <sip:10.***.*.*>;method="NOTIFY;Event=telephone-event;Duration=1000"
    Supported: timer, 100rel
    P-Asserted-Identity: "7**********"<sip:7*********@10.***.*.***>
    Content-Length: 0

    Please advise

    Cheers

    D
     
  2. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    just updating my own post- it seems looking at our fax log that t-38 is being rejected by our VoIP network -is there a way to switch off t38 or fallback to G711?
     
  3. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    This was resolved by changing the route on our voip network so it accepts t38 traffic-its a puzzle that the fax worked previously without t38 with the previous version
     
  4. n2

    n2

    Joined:
    Nov 8, 2010
    Messages:
    16
    Likes Received:
    1
    Can you advise what you did to change the route? I asume you changed some firewall settings, but am uncertain and would appreciate the clarification as I think I may have the same issue.

    Thanks,
    Larry
     
  5. dazred

    Joined:
    Nov 3, 2009
    Messages:
    12
    Likes Received:
    0
    Hi

    Sorry for the confusion, the VOIP provider allowed t38 traffic through. No changed were made to the firewalls
     
Thread Status:
Not open for further replies.