3CX Firewall - testing 3CX SIP Server... failed

Discussion in '3CX Phone System - General' started by Elvin Mammadov, Feb 10, 2017.

Thread Status:
Not open for further replies.
  1. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    Hello,
    I have installed 3CX with standard license yesterday. It is working okay, but when checking firewall in 3CX, I get an error as following. Why this happens?
    • resolving 'stun.3cx.com'... done
    • resolving 'stun2.3cx.com'... done
    • resolving 'stun3.3cx.com'... done
    • testing 3CX SIP Server... failed (How to resolve?)
      • stopping service... done
      • testing port 5060... failed
        • testing port 5060... not reachable
      • starting service... done
    • testing 3CX Tunneling Proxy... done
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    353
  3. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    Yes, we have installed 3CX without NAT and 3CX automatically opened all required ports in Windows Firewall. I checked port scanner on http://www.yougetsignal.com/tools/open-ports/ and 5060 port is shown closed but 5090 port open. While 5060 is shown closed, calls through 3CX are made flawlessly. We have used 13060 and 13090 port in our previous 3CX V14, and it worked well. But in V15, just in case I also changed ports from 5060, 5090 to 13060, 13090 and checked open ports in yougetsignal.com, it showed these ports are open, but when I use firewall checker in 3CX, the same issue comes again.
     
  4. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    Which sip ports do you advise to use if 5060 port is shown closed by provider?
     
  5. Sopock

    Sopock Member

    Joined:
    Jul 11, 2012
    Messages:
    447
    Likes Received:
    20
    That is one advantage of SBC which can be used for remote location:
    • Overcome difficulties with ISPs that block VoIP Traffic based on port numbers
    13090 is unusual for SIP port?:confused:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #5 Sopock, Feb 11, 2017
    Last edited: Feb 11, 2017
  6. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    We are using only softphones, not deskphones and our office doesn't have branches. In our country, ISPs always block 5060 port, so we always try use another sip ports. Previously we have used 13060 and 13090 tunnel port, but it didn't work properly. I wonder, ISP blocked 5060 port, but it is still working. In this website, there are bunch of sip ports for 3CX, but I don't know exactly if they are good choice. http://vob.ozbeanz.com.au/2014/07/28/3cx-cloud-server-port-list/.

    Can I use 5062 port instead of 5060? Secure SIP:5061, Tunnel Port 5090?
    If not, can I use SIP Port: 6060, Secure SIP:6061, Tunnel Port 6090?

    SIP Port, TCP/UDP, 5060,6060,7060,8060,9060

    Secure SIP Port, TCP, 5061, 6061, 7061, 8061, 9061

    Tunnel Port, TCP/UDP, 5090, 6090,7090,8090,9090
     
    #6 Elvin Mammadov, Feb 13, 2017
    Last edited: Feb 13, 2017
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    353
    Yes you can but this will change both internal and external SIP port. This will affect PnP provisioning but if you are using only softphones that should not be a problem. Navigate to Settings /Network / Ports change the ports to the desired ones and restart all services.
     
  8. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    ok, since I am new to 3CX, I want to make sure which option is right in this case?

    1. Sip port: 5062, SecureSIP: 5061, Tunnel port: 5090
    2. Sip port: 5070, SecureSIP: 5061, Tunnel port: 5090
    3. Sip port: 6060, SecureSIP: 6061, Tunnel port: 6090

    SIP Port, TCP/UDP, 5060,6060,7060,8060,9060
    Secure SIP Port, TCP, 5061, 6061, 7061, 8061, 9061
    Tunnel Port, TCP/UDP, 5090, 6090,7090,8090,9090
     
  9. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    353
    Please note that you can change SIP port and tunnel port. Not the secureSIP port.

    Options 1 and 2 will work in your case.
     
  10. Elvin Mammadov

    Joined:
    Feb 3, 2017
    Messages:
    42
    Likes Received:
    1
    Thank you very much. I selected first option 5062 port and it is working okay. But could you please clarify me, ISP blocked 5060 port, but why voip calls was working okay?
     
  11. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    353
    This is something your ISP can clarify i think. if indeed the port 5060 is being blocked then you should not have been able to perform calls.
    Glad to hear it is working now
     
Thread Status:
Not open for further replies.