3cx gateway for skype problems

Discussion in '3CX Phone System - General' started by Paulc, Jun 28, 2009.

Thread Status:
Not open for further replies.
  1. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    I have installed a copy of the 3CX gateway for skype (Ver 2.7.7919.0) on to my machine with a copy of Skype ver 4.0. When i click on the 'skype' button it comes back with an error ' No Skype Support ' , "no skype support available - requires interactive support'

    Any Suggestions

    Thanks


    Paul
     
  2. matictec

    matictec New Member

    Joined:
    Mar 31, 2008
    Messages:
    188
    Likes Received:
    0
    i had the same problem with the msi-package of skype. use the version for private use and choose standard-install.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,476
    Likes Received:
    67
    Hi, Paul, Martin

    Basically it means the Skype has not been installed with its "Skype Extras" option checked - this Extras, even is not used by the gateway, it's required because it contains the "link/bridge/glue" needed support object (a dll). This is an issue we found quite very late - for instance, Skype Bussiness even doesn't come with this component - thus starting from next release, that dll will be included in the gateway's installation kit (+ ~1.8MB) since it can be redistributed. Sorry for this inconvenience.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    Hi Guys,

    Thanks for the advice, i will try and reinstall skype onto the machine

    thanks


    Paul
     
  5. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    Hi Guys,

    I have reinstalled Skype v4.0 and the skype gateway is now active. However when i try to dial an external number via 3cx phone dialer it comes up not available.

    I am registered with the correct extension number as setup in the PSTN gateway. I have also setup an outbound rule to dial 0 before the number.

    Any ideas please

    Regards




    Paul
     
  6. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,476
    Likes Received:
    67
    Hi, Paul

    Paul, gateway never responds with "not available" to PBX. Such kind of message on your phone generally means the gateway even cannot not be found (or "reached").
    Check following things:
    - if, when you make the call, the gateway's port you call is "green" into the monitor. If not, check why and try again when it's "green".
    - if the gateway's port is green, then definitely it's a problem of PBX configuration. To try to figure out, open PBX's Management Console and, on the left tree, go to Settings/Advanced section. On the bottom side of the page, check "verbose" logging level, then click Apply, OK, and then, from Services Status section, restart 3CX Phone System. After that, wait until gateway become registered (green) and make the call. When call ends, in the Management console open the "Service activity log" - and check from last INVITE you see, to top of the page, you should find the reason.

    Quite complicated this second procedure :mrgreen:

    Good luck

    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    Hi Vali,

    I have attached a copy of the activity log. I've checked that in the Gateway for skype that the port id is (green) and it says that the skype account is online ok. When i still try to dial an external number it comes back as 'not available.

    Help, im very confused.

    Many Thanks


    Paul

    :oops:
     

    Attached Files:

  8. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,476
    Likes Received:
    67
    Hi, Paul
    Paul, I struggled quite serious with your logfile to understand what's going on :mrgreen:
    So, finally I think I realised the configuration you have, and is not a correct one:

    1 - you created an external line (most probably, a PSTN one, as gateway requires) named Skype, having as "number" 104.
    2 - most probably, that leads you to create an outbound rule, where you set 0 as prefix and strip 1 digit
    Ok, until now is almost perfect (I will explain you later why "almost"). Now it's coming the interesting part:
    3 - you registered your 3CX Voip Phone (callerID "Desktop") as 104 - and it registered perfectly, displaying "On Hook".
    4 - on the phone, you dialed 0077xxxxxxx (expecting to pass through outbound rule) and you got "Not Available".

    Well, the wrong-critical part in this configuration is registering phone as 104, therefore as an EXTERNAL LINE, not as an EXTENSION. A phone always should be set as an extension. If you register it as an external line (PSTN gateway) PBX will consider its "calls" as external-inbound ones and they will be processed according to the gateway settings you defined. In your case, PSTN gateway 104 has the default "routing during (out-of-)office hours", respectively "connect to extension 100". Which extension seems not registered, therefore your "calls" will get, normally, "Not available" message.

    To fix this, let your PBX as is but:
    - register your phone as an existing EXTENSION (let's say 101)
    - stop Skype gateway and configure its port as the existing 104 PSTN gateway (probably 104/104/104 port 5061, hmm, not too good choice 5061) then start the gateway.
    - from your phone, now try first an 0echo123 - this calls Skype's sound service. It should work
    - then try to call 0077xxxxxxx, it should work also.

    The difference is following: as you already observed, in previous configuration outbound rule has not been involved. Now, the call you made 0echo123 coming from EXTENSION goes to PBX, PBX found outbound rule, strips 0 and pass the echo123 to the 104 gateway - our Skype gateway - which will call Skype with echo123.

    I said earlier the configured PSTN gateway is almost perfect: is not recommended, for troubleshooting purposes, to register an EXTERNAL line with the same number of digits as extensions, it's very confusing.

    Ok, lesson is done, hope it helps :mrgreen:

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    Hi there,

    I have done everthing that you have recommended to do but i now get 'destination busy' when trying to dial anything.

    I think that it maybe is trying to dial the extension number that im using '100' and not using 104 (virtual)

    please advise


    Paul
     
  10. Paulc

    Joined:
    Jun 28, 2009
    Messages:
    6
    Likes Received:
    0
    Hi Guys,

    When i try to dial a number via the skype gateway , it says ringing (then you can hear the skype tune for calling a number, but the number just rings and rings, however the phone number im ringing is not ringing, if that makes sense

    Any one got any ideas please



    Paul
     
  11. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,476
    Likes Received:
    67
    Hi, Paul

    I'm not using messengers - including Skype - too often, so I'm not familiar with this kind of issue to provide you an answer; it might be related with credit amount available, with called account, who knows. The only advice I can provide you here is: stop the gateway, open your Skype (by the shortcut Skype installed) and from this one try to make the call to the destination you want, to see if has the same behavior. If yes, then you have only a Skype issue to fix, not a Skype-gateway-PBX-OS one.

    In the next release, we will provide an option for configuration mode, to allow user to use Skype "as-is" - in this version, in configuration mode Skype rejects with "busy" inbound calls, because configuration mode is considered a "maintenance operation" of the gateway and would not be convenient to get (alot of) inbound calls when the gateway is not working.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.