Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX, Gmail & IPCop

Discussion in '3CX Phone System - General' started by DexDeadly, Dec 12, 2012.

Thread Status:
Not open for further replies.
  1. DexDeadly

    Joined:
    Dec 12, 2012
    Messages:
    55
    Likes Received:
    0
    I have the free version and I am using the DEMO key at the moment. I'd like to upgrade soon as I get things off the ground but I need to make sure I can get this setup working first. Right now I have my 3CX server behind my IPCop firewall. Everything works incoming calls and the like. I like what I can do very much. The only thing I can't seem to get configured is sending email notifications. I tried multiple combinations of a Free SMTP server and the one in IIS. I have 3CX installed on my Windows 2008 Standard Edition server. I have IIS installed running the web interface. I have made sure my IPCop allows the outgoing port. Atleast I believe so. What is the best way to get this working. I want to use my gmail account to send the information. I need this fixed so that I can get my fax working as well.

    I might just be getting myself worked up seeing as I have a bunch of business cards on the way printed with fax and phone and I need this to work. Anyone able to please please please help me out here?
     
  2. DexDeadly

    Joined:
    Dec 12, 2012
    Messages:
    55
    Likes Received:
    0
    Nevermind I was able to do it. If anyone was curious this is how I ended up making it work correctly.

    I started off using this document.

    http://www.3cx.com/blog/docs/send-emails-ssl-tls/ however the setting up of the SMTP server was not clear enough and missing some information. So I then followed these steps to setup the IIS with Gmail for relaying.

    http://www.jppinto.com/2010/07/how-to-configure-iis-smtp-server-to-forward-emails-using-a-gmail-account/

    Once I did this I tested using the send welcome email link under extensions and it came through. Thought I would put this out there since I had seen some other people trying to do this and didnt have any luck.
     
  3. fellatarik

    Joined:
    Mar 17, 2013
    Messages:
    2
    Likes Received:
    0
    Hi,
    i also try and finaly it work
    i but : smtp.gmail.com:587 in the server name
    my Gmail user, name , password and it work fine..lol :D
     
Thread Status:
Not open for further replies.