3CX goes asleep

Discussion in 'Android' started by ughridk, Feb 5, 2011.

Thread Status:
Not open for further replies.
  1. ughridk

    Joined:
    Feb 5, 2011
    Messages:
    4
    Likes Received:
    0
    I'm running 3CX on an HTC Desire Z (Android 2.2).

    Everything works very well except for one thing. When I don't use my phone, after a few moment, the softphone doesn't keep registered on the VOIP server. So, it is unstable for receiving calls. Is there a specific set-up I can configure to avoid that?

    Thanks to anyone has the answer.

    ughridk
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Are you using it with 3G or over WiFi? Have you tried it on both, same thing? Have you tried it on more than one WiFi hotspot? I found, in the past that my WiFi SIP phone would loose registration, after 10 minutes or so. on certain sites, but be just fine after an hour, on others.

    What is your registration Timeout and Keep-Alive Intervals set for? Those are about the only options that might affect this. I find that even when I hit the "back" button to clear the phone from the screen, the green dot in the upper left corner indicates that I'm registered. I haven't tried leaving it up for more than an hour or so. This is all over WiFi as 3G doesn't pass audio for me.

    Could there be a battery saving App that is turning off WiFi after a given time?
     
  3. ughridk

    Joined:
    Feb 5, 2011
    Messages:
    4
    Likes Received:
    0
    I almost always tried over wifi. 3cx works well on the 3G network but did not try to receive calls yet.

    I played with these 2 setups : Registration timeout and Keep-Alive. I've changed them and found that with for some configurations, it takes a longer time before loosing registration. Unfortunately, I still did not find a recipe which will always keep my registration alive.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Have you checked that it's not the phone, loosing it's assigned IP, and having to ask for another, for all web applications, and not just the 3CX phone? Could WiFi itself just be shutting down after a given time?
     
  5. ughridk

    Joined:
    Feb 5, 2011
    Messages:
    4
    Likes Received:
    0
    I don't think my network is the problem because :
    1- I also have 3CX installed on my PC (Windows 7 64 bits) and it always stays connected on the server. My PC uses wifi.
    2- I also have a digital-analog adapter (Linksys PAP2T) connected to my network and it works very well too. This box uses an ethernet connection on my router.

    Both (the PC and the PAP2T) always stay registered on the voip server.

    I would also like to say that, on my Android phone, the green dot in the upper left corner stays on even if the 3CX softphone loses its registration. At the second I open 3CX, "registering..." appears on the screen.

    Actually, I'm set like that:
    Registration time-out : 3600
    Keep-Alive Interval : 300
    Lock wi-fi : Always
     
  6. mmoreice

    Joined:
    Sep 22, 2007
    Messages:
    3
    Likes Received:
    0
    Same problem here. I used sipdroid before, It has the same problem.
    Maybe we should not search the solution in the Sip-client, but in some Android-settings?

    Cheers, MmoreIce
     
  7. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,473
    Likes Received:
    94
    Try going in the Settings > Integration > Lock Wifi and select always.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. ughridk

    Joined:
    Feb 5, 2011
    Messages:
    4
    Likes Received:
    0
    @LeonidasG
    If you read my previous message, you should have seen that Lock-wifi is already set to Always.
     
  9. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    Same problem here.
    Locking WIFI doesn't work. It's not the WIFI connection which is desconnection while screen is off.
    I found out that sometimes when I'm doing something else on phone the connection also disconnects somehow. Green symbel doesn't change to red. When I want to open the 3CX screen is quickle register the tunnel again and it's up and running. Keeping the screen on helps but it's definately not the ideal situation.
     
  10. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Try reducing the registration time in SIP client to 900 or 1800 seconds (3CX default). If set to higher value, the SIP client may become unregistered after 900 or 1800 seconds from last registration.

    The PAP and other SPA adapters will re-register each 900 or 1800 seconds despite of their own settings (default is 3600) -- imposed by 3CX server.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the advice but unfortunately none of these settings seems to solve the issue.
    When not using the tunnel the registration is up and when using tunnel it loses registration after turning screen off. But the green dot does not turn red. It just says it is registering when turning screen on.
     
  12. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    I still have the problem when openening the 3cx with the icon in status bar. It quickly registers and says it's on hook. Before tapping to open the 3cx it was already registered and the dot was green.
    I found out that if the main screen of 3cx isn't open then after a short period I can't receive calls when screen is on. But leaving the screen open it works like a charm when screen is on. It has nothing to do with wifi though since I have tested it wth 3G. I also found out I can receive calls when the main screen of 3cx is open and the phone screen is off. But when main screen is not open but still running with screen off it won't receive calls after a short period. Very strange. I don't have any third party apps for controlling apps.

    I'm using the tunnel by the way.

    I'm using 1.3.2 version.

    Anyone has this problem as well?
     
  13. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    #Deleted#
     
  14. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    I thought I found the problem but it still bugs me.
    It seems like after a certain period the app closes but the green dot is still there which says registered.
    Even when the screen is on the 3CX app starts up when I click the green dot in status bar. It says it's tunneling and registering. This doesn't happen everytime. It seems like if I use other apps and then return to 3CX it re-registering. Is it possible the app is closed by Android itself? I'm almost capable to pull all my hair out of my skull. I can't trust that it's still registered when phone is idle.
     
  15. mcse17

    Joined:
    Oct 15, 2011
    Messages:
    2
    Likes Received:
    0
    Hi,

    I have the same problem on DesireZ, however I know someboday with a Galaxy Tab and it doesnt cause a problem for them when they switch to different apps and back to 3CX.. it still shows on HOOK and is connected..! Also someone with a HTC Desire doesnt have this prob either..? I have Android v2.3.4 running and the Tab has 2.2, I looked to see if there was some kind of takmanager killing the app but couldnt find anything..
     
  16. Shoedt

    Joined:
    Aug 12, 2011
    Messages:
    8
    Likes Received:
    0
    I am also using the latest android version and also latest 3cx android. I was testing without closing the main 3cx screen and just turn off screen. This definately prolongue the registration and keep it registered somehow. As soon as I go to other app or just to home screen the registration will be lost after a short while. Not sure what is causing this problem. It's driving me mad.

    Could it be possible the built-in task killer is closing the app? However the green dot is still in upper task bar. It never turns red by the way. It is green all the time.
     
  17. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    It is possible depending on how it is set up/what criteria it uses to kill a task. Perhaps the WiFi is being shut down if not used after a given time. I don't have the issue using a Desire. It could be something that is handset model specific.
     
  18. SnelleEdje

    Joined:
    Nov 6, 2011
    Messages:
    19
    Likes Received:
    0
    Well, I have a Desire as well and see the same problem. One night left it connected via mobile network and the next morning the logfile was filled with "unregister" and register messages. The light was green all the time (as far as I could see). 3CX was running in the foreground all the time and the screen was off. If the screen is on, my Desire stays registered.
    I was wondering if this could be a general Android problem, but not everyone seems to have this problem.
    Still testing....

    Regards,
    Edwin.
     
  19. SnelleEdje

    Joined:
    Nov 6, 2011
    Messages:
    19
    Likes Received:
    0
    A little update on testing.

    The new version 1.3.4 still has the same problem (on my Desire).
    When it is registered via mobile network, it will loose it's registrations every few minutes and will then register again. This happens when the screen is off. There is no fixed interval. Sometimes, when I switch on the screen, I see the phone starts registering, although there was a green dot on top. In the logfile you might see a registering message and a few minutes later another one, without an unregister message in between.

    My Desire works okay when it is registered via wifi on the same LAN where my PBX is. It stays registered, screen on and off. I didn't try it via another wifi network yet.

    Regards,
    Edwin.
     
  20. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    What do you have the registration interval set for? The maximum is 30 minutes (normally) but can be set lower.
     
Thread Status:
Not open for further replies.