Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX Ignoring Office Hours on All Levels

Discussion in '3CX Phone System - General' started by Weston Williams, Dec 20, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. Weston Williams

    Joined:
    Dec 20, 2017
    Messages:
    3
    Likes Received:
    0
    3CX is completely ignoring Office Hours, no matter which level they are set. I can set office hours at the System, SIP trunk, DID, CID, or Extension level... nothing makes one bit of difference. Everything always takes the "In Office" path. Everything else is obeyed.

    For example, if I set a CID Inbound Rule for my cell to rout to Ext 1 during office hours, and Ext 2 out of office hours, it will ALWAYS go to Ext 1. This is not a time zone issue: If the office hours are set up as 8:00 - 8:30, ONLY on Mondays, the system still routes me to Ext 1 every day of the week. I can change forwarding to Ext 3 during office hours, and it will obey this without issue, so there's no problem picking up the CID and following that part of the rule. It shows up exactly as expected in the call log. It just won't recognize office hours.

    This occurs at every single level. I've tried a blanket system setting for Office Hours, identical at every level:

    - Time Zone, Office Hours & Holidays (under settings)
    - SIP Trunks (there's only one)
    - Inbound Rules (DID, CID)

    If I set every single one of these as being "In Office" ONLY from 8:00 to 8:30 on Mondays, then (again, on every level where this is possible), set forwarding to Ext 1 during office hours, and Ext 2 out of office, it will always forward to Ext 1.

    I can remove all Office Hours settings, and apply only one inbound rule as above. Again, same result.

    I've set up dummy extensions with forwarding exceptions based on caller ID and specific timeslots. These recognize the CID just fine... and ignore the time.

    Once again, definitely not a Time Zone thing where there's an offset that's not accounted for. If anyone has any suggestions, please let me know.

    3CX Version: 15.5.1694.0
     
  2. Weston Williams

    Joined:
    Dec 20, 2017
    Messages:
    3
    Likes Received:
    0
    Quick update: We've installed the latest updates and services packs as of 2017-12-20. We're now on 15.5.6354.2.

    Thank You!
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,445
    Likes Received:
    540
    Hello @Weston Williams

    Try something simple as a first step. Remove all office hours and just set office hours on an extension and enable the auto switch option. Once the extension reaches the time that is out of office check the status of the extension and see if it has gone to DND. This should give you an idea whether or not the system switches between office hours or not. Also have you checked the servers time? I know you mentioned that this is not the cause but it is the most common reason for office hours not being obeyed.
     
  4. Weston Williams

    Joined:
    Dec 20, 2017
    Messages:
    3
    Likes Received:
    0
    Hi YiannisH_3CX. Thank you for your response.

    I've already tested each individual level, including what you recommend above, with all other Office Hours options turned off.

    Of course I've checked, and double-checked, the time and time zone on the local server and in 3CX itself. Everything is fine, and all call logs, voicemails, and other time-bases entities report exactly as they should. This server is on a domain, and it looks to the DC as NTP server. The DC loops through primary and backup public NTP servers and is correct to the second. I understand that this could cause the behavior, which is why I checked multiple times, in multiple ways. I also configured the ludicrous Office Hours setting for only Monday from 08:00 - 08:30... just to make sure I fell outside the range.

    There's clearly an issue with time-based settings or services on this 3CX instance. There are no other problems. Every entity, at every level, completely ignores Office Hours, no matter when or where they're set. That's it...

    Let me know if you have any other suggestions.

    Thanks,
    Weston
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,445
    Likes Received:
    540
    This does sound strange and we will need to further investigate. I have sent you a p.m.
     
  6. JWillScott

    Joined:
    Nov 18, 2017
    Messages:
    12
    Likes Received:
    3
    @Weston Williams
    Do you have a dial code setup to force 3CX In/Out of office hours?

    Settings > Dial Codes > Force 3CX Phone System to IN or OUT of office
     
  7. SteveX

    Joined:
    Dec 29, 2017
    Messages:
    4
    Likes Received:
    0
    I have exactly the same issue. My client works from 5am till 9pm. so over the holidays I had to get up at 5am every morning to sort it manually. Is there any update to this.
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,445
    Likes Received:
    540
    Hello @SteveX

    What version PBX are you running? Are you on windows or linux? Is the server time correct?
     
  9. SteveX

    Joined:
    Dec 29, 2017
    Messages:
    4
    Likes Received:
    0
  10. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,445
    Likes Received:
    540
    Are you using global office hours or specific office hours? Is it the same behaviour on extensions trunks etc?
     
  11. SteveX

    Joined:
    Dec 29, 2017
    Messages:
    4
    Likes Received:
    0
    3CX support gave me the following information.

    In the Dial Code area, in the "Force 3CX Phone System...." option enter *64, then press OK .

    [​IMG]



    Once you do this, it means that you will have 3 dial codes:

    • *640 -->Use the default office hours (this is the state you want)
    • *641 -->Force the PBX In Office Hours (never goes out)
    • *642 -->Force the PBX Out of Office Hours (never goes in)

    So once you input the dial code as mentioned above, from any extension on your system dial *640 and you should hear a message "3CX Phone System is now using the default office hours".

    After you do this, try to see if the call routing now obeys the Office Hours.

    I have used *9 as the dial code in my setup and followed the instructions here https://www.3cx.com/docs/pbx-dial-codes/#h.665f9ex1w4m3

    Following this guide I was setting the system to auto enabled by dialing *9 from an extension. I still received the conformation message that the system was using default hours but it wasn't changing from IN Office to Out of Office. Adding the O has worked in my tests so far. I'll do a bit more testing and let you know if this is a proper fix.
     
Thread Status:
Not open for further replies.