Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved 3Cx IOS working but getting timeout

Discussion in 'iOS' started by Joao Custodio, Feb 15, 2018.

Thread Status:
Not open for further replies.
  1. Joao Custodio

    Joined:
    Feb 1, 2018
    Messages:
    7
    Likes Received:
    0
    Hi,

    I have the 3CX system setup, firewall checker is all green and all works fine on the internal network, from the outside when I open the IOS app it registers and on the top right states "On Hook", if I try calling an internal extension it rings but under the user photo I keep getting error messages in the following order: "Connecting"... "Timeout"... "Connecting"... "Error 405".
    On the Management console Event log I can see the extension registered.

    Thanks in advance
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    Hi Joao

    Our PBX doesn't answer back with 405 (Method not allowed). Since you mentioned the error is shown under avatar, it means is related to the MyPhone server (which, also, doesn't reply with 405). So, our advice is to check the NGINX server logs to see if/why it response back with this code. If you don't see there the iOS client' request, then you have to check your network environment (for proxies, for instance) to figure out who intercept the request and why it answers back with 405.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    Joao Custodio likes this.
  3. Joao Custodio

    Joined:
    Feb 1, 2018
    Messages:
    7
    Likes Received:
    0
    Hi Vali_3CX,

    Thanks for the quick reply, I hadn't payed the right attention to our NAT configs, we had port 5001 NATed to a NAS file station, after changing it to the 3CX server all started working perfectly.

    Thanks
     
Thread Status:
Not open for further replies.