3cx IVR xfer to Voice Mail System 9999

Discussion in '3CX Phone System - General' started by wired1, Sep 4, 2016.

Thread Status:
Not open for further replies.
  1. wired1

    Joined:
    Oct 5, 2010
    Messages:
    17
    Likes Received:
    2
    We are setting up an IVR that once done it will transfer the user to the voicemail system. Not to the voicemail of an extension but to the "enter the voicemail box number then enter the PIN" in previous versions you could choose an option that would allow you to transfer to the Voicemail Box Extension by choosing it in the drop down of extensions now it doesn't show. This feature is needed for our on-call staff to retrieve the after hours voice mail left by clients but now they have to enter the 9999 when the IVR is called. Is there a way to fix this in a system setting or is this no longer available in V15?
     
  2. AlanM

    Joined:
    Aug 3, 2010
    Messages:
    39
    Likes Received:
    0
    I too am wondering how to do what 'wired1' is asking regarding accessing the VM system, where the user is prompted for a mailbox and pin. I just updated from v14 to v15 today and used this feature a fair amount when outside the office. A definitive how-to or even can't do would be appreciated.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tratz

    tratz New Member

    Joined:
    Oct 21, 2015
    Messages:
    109
    Likes Received:
    15
    I would create a IVR entry or a DID to 9999. This way when it reads in the from caller id it won't recoginze any extensions and will prompt you for the extension and pin.

    --Tracy
     
  4. wired1

    Joined:
    Oct 5, 2010
    Messages:
    17
    Likes Received:
    2
    Tracy,
    Thanks for the input on this. I have tried many different ways to do this and looked for the one you suggested but the IVR can't have the same extension as the VM System Extension of 999 or 9999 in my case.As for the did you can only assign in version 15 via an inbound rule which doesn't seem to work either. I called support on this and the rep told me to put in a ticket as this was not right and should have the option to transfer to the 999 extension when a number is pressed or a transfer to extension is selected. Thanks for the info and if I am misunderstood what you are saying let me know.
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    352
    Hi there i can think of a couple of ways to achieve this since it will used by your stuff.
    A way to achieve this is by creating a dummy extension.
    Set it to do not disturb and in the forwarding rules of the extension under the do not disturb status set it to forward external calls to Forward to Number option and type 9999.
    Of course you will have to set this extension as a key that can be dialled through the IVR.

    another way is by having a dedicated DID for this. Create an inbound rule where you set as destination the dummy extension that forwards the call to the 9999 voice mail extension.

    hope this helps
     
  6. AlanM

    Joined:
    Aug 3, 2010
    Messages:
    39
    Likes Received:
    0
    YiannisH, thanks for your suggestion; the solution will probably work. I will give it a try in the next couple of days.

    I did something similar at another location in a previous version (v10) to get a user's desk phone and their mobile phone to ring simultaneously; checking the box to do this did not work consistently well.

    I do wonder, though, why this functionality was removed from v15.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. tratz

    tratz New Member

    Joined:
    Oct 21, 2015
    Messages:
    109
    Likes Received:
    15
    Alan:

    Create an IVR call it extension 818 and then one of the option send the call to extension 9999 which should prompt the user for a voicemail pin. The other option is when it rings and it says press your pin. Press the # button and then VM should prompt you for extension and pin code.

    --Tracy
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,425
    Likes Received:
    352
    The functionality will return in one of the future releases of V15. When will this be exactly is something we do not know as of yet
     
  9. GtInNoVaTiOn

    Joined:
    Mar 9, 2016
    Messages:
    13
    Likes Received:
    4
    I had this same problem and did this workaround. Create a ring group that rings a virtual extension for 0 or 1 seconds and then go to 999 if no answer. 15 allows routing to 999 in this menu.
     
  10. AlanM

    Joined:
    Aug 3, 2010
    Messages:
    39
    Likes Received:
    0
    Thanks GtInNoVaTiOn. That seems to work (though v15 requires a value between 1-65535 seconds).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. AlanM

    Joined:
    Aug 3, 2010
    Messages:
    39
    Likes Received:
    0
    Now that I am able to remotely access the VM system, when prompted for extension and PIN number, I am receiving an invalid PIN response. I checked the extension configuration where the option "Disable Voicemail PIN Authentication" box was checked. I have this checked so that I do not have to enter a PIN when I am at my desk. If I uncheck this box, when prompted for the extension and PIN, the remote access accepts the PIN and allows me into the voice mailbox. In v14 SP 2 remote access prompted for, and accepted the PIN with the "Disable Voicemail PIN Authentication" box checked.

    I wonder if this is by design or a bug? I understand the security of a PIN for voicemail but in a SOHO setting, I really do not need it. Not a big deal; just a slight inconvenience.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.