3CX license on domain controller

Discussion in '3CX Phone System - General' started by dpardoen, Jan 14, 2009.

Thread Status:
Not open for further replies.
  1. dpardoen

    Joined:
    Jan 14, 2009
    Messages:
    6
    Likes Received:
    0
    3CX version: 7.0.4744

    Hello,

    When i try to register my key (Small Business Edition) for the v7, it tells me that my key is accepted and that is has to restart...

    I read the other posts about adding the ASPNET user to the Power users group but thats not possible in our situation.

    Situation: Serer 2003 R2
    Role: Domain Controller / Exchange server

    Could somebody please advice how to activate the license. So far v7 isn't out of the box software, al lot of issues on different servers.
     
  2. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Is the license being accepted?
    What happens when you restart the 3CX services?

    I assume the server has internet access?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. dpardoen

    Joined:
    Jan 14, 2009
    Messages:
    6
    Likes Received:
    0
    Dear "discovery1",

    Is the license being accepted? Yes, the system shows the right information.
    What happens when you restart the 3CX services? Then the information i putin the fields disappear. This also happens when i go to another option and then return to the license section. He wipes the fields and puts in the FREE edition.

    I assume the server has internet access? Yes, It's a production DC, Exchange server.

    The behavior what happens is the same as in post ( http://www.3cx.com/forums/v7-refusing-my-license-key-after-6-1-upgrade-8225.html )but it's a domain controller.

    It's very good possible that it has to do with rights. But witch one or on what directory or service?

    Please help.

    Daniel
     
  4. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Hi Daniel

    Since your server is 2003 and also a DC and running exchange, then you should start by looking at the IIS6 configuration - can you check the correct application pools are assigned to the 3CX virtual directories?

    This is from another post:

    The 2 virtual directories ('management' and 'myphone') and the website 'IVR' have to be on the same application pool. in this case the application pool that has the rights needed to perform all necessary 3CX functions is the application pool we create in the installation called the '3cxApplication Pool'. Double check that this exists by accessing the IIS interface (Start/Run/inetmgr). You should see the 3cx application pool the moment you expand the application pool tree node.

    Next confirm that management, myphone and Ivr are all pointing to the 3cx application pool.

    Expand the tree node 'Default Website'. Inside it you should see a virtual directory called 'management' and another one called 'myphone'. Confirm that the 3cx application pool is assigned to both these Virtual directories. (There is a known issue in 3cx that in some scenarios, the 3cx application pool is not assigned to an application that resides under the 'default website' in IIS and leaves the application runing under the Default Application Pool.) Right click on Management and click on properties. Click Virtual Directory or Home Directory Tab. In the Application pool list box, select the 3CXApplication Pool name to assign management to the Application Pool. Do this for both IVR and Myphone Applications.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.