3CX Mobile PUSH not working for new extensions

Discussion in 'iOS' started by Kneza, Apr 12, 2018.

Thread Status:
Not open for further replies.
  1. Kneza

    Joined:
    Aug 15, 2017
    Messages:
    10
    Likes Received:
    0
    Hi,
    I don't know for how long (maybe 1-2months?).. I have a problem with new extensions.
    We have more than 150 extensions, where push is working, but on new extensions it is not - there is problem with status of people. Once the application goes on background, extension is logged out and he is offline, then he cannot be reached by anybody...
    I tried to disable push on extension and reenable again, delete account, create new... nothing... right now, it's not working for 3 last created extensions...
    Any idea? How to debug why it's being logged out?
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,468
    Likes Received:
    66
    Hi @Kneza
    The presence icon for these extensions appears gray in the Management Console or other phone's Presence view? If yes, it means there is something wrong on the push service on the PBX side, so a full PBX restart might solve the problem. A push-enabled device never appears as gray/unregistered, since its associated push service is, in fact, another, registered contact for its extension.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Kneza

    Joined:
    Aug 15, 2017
    Messages:
    10
    Likes Received:
    0
    Hi @Vali_3CX ,
    yes, he is greyed:
    upload_2018-4-12_14-14-19.png

    PUSH is enabled:
    upload_2018-4-12_14-15-32.png

    I have already tried to do full server restart, without success :-(
     
  4. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,468
    Likes Received:
    66
    Can you tell us the PBX version (including SP, if any) and iOS client's one (as in Settings/About) ?
    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Kneza

    Joined:
    Aug 15, 2017
    Messages:
    10
    Likes Received:
    0
    Hi @Vali_3CX ,
    PBX is running latest version 3CX Phone System v15.5, Update 4, Build 15.5.10244.4, March 2018: upload_2018-4-12_16-52-16.png
    iOS client is running also latest non-beta version:
    upload_2018-4-12_16-53-22.png

    I think, that with clean 15.5 it was working okey for new extensions, but with some of SP it stopped..
     
  6. Kneza

    Joined:
    Aug 15, 2017
    Messages:
    10
    Likes Received:
    0
  7. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,468
    Likes Received:
    66
    @Kneza
    Well, with the 3CX client I can assist you to figure out if the problem is on its side, but with the PBX... I'm the last person to ask for help :D

    OK, for the 3CX client, you will need a MAC or Windows computer; if Windows, you will have to install iTunes for Windows. Once you have the iTunes running, plug the iPhone into computer, trust it, then in iTunes click the iPhone icon which appeared on the toolbar; on the left tree click the File Sharing; in the right panel, in Apps, click 3CX; next to it will appear "3CX Documents" list; click "sys.log" then scroll down until you will see a "Save" button; click it then save the sys.log somewhere on your computer. You're done with iTunes. On your computer, open the saved sys.log with a text editor (Notepad++ preferred) then search for "PUSH token:". So far so good. Now, if you see its value something like <http://apple.com>;token=blababla, it means 3CX is properly set for PUSH; but, if if empty [] or token is missing, then here is the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Kneza

    Joined:
    Aug 15, 2017
    Messages:
    10
    Likes Received:
    0
    Hi @Vali_3CX ,
    here is sys.log from iphone.
    PUSH token is there, apple token blabla also... BUT there are also unregistering steps.. as app is put on background, everybody see this extensions grey and in 3cx administration it's red:
    upload_2018-4-20_14-8-21.png
     
  9. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,468
    Likes Received:
    66
    @Kneza

    The log it's OK (I've deleted it; do not make public private info!!) the unregistering is OK, it's the one triggering/activating PUSH on the server.

    My advice is to contact our tech support, to assist you on the PBX side.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,468
    Likes Received:
    66
    @Kneza
    I've got some news for you:

    my test extensions (with push support, obviously) suddenly appeared gray on other phones' Presence (i.e unregistered) and push was received only for chat and missed calls, not for calls. After digging, we found that on the PBX the Queue Manager service crashed - and this service is involved in push calls. Once restarted, extensions became green and push calls properly working.

    Hope it helps (for me, definitely was a good KB feedback)
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.