3CX MyPhone shows CID as Private Number

Discussion in '3CX Phone System - General' started by habros, Jul 26, 2012.

Thread Status:
Not open for further replies.
  1. habros

    Joined:
    Jul 25, 2012
    Messages:
    5
    Likes Received:
    0
    Hi all,

    When a call comes in, CID works/shows properly until it hits Que. After that MyPhone show CID as as Private Number while the 3CXPhone still got the proper CID. Any idea?

    TIA,
    Dave
     
  2. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    666
    Likes Received:
    5
    Seems that this is by design. Regular users can not see CID of other users. Or, this can be a bug... I have the same problem, by the way.
     
  3. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    666
    Likes Received:
    5
    Seems that this is by design. Regular users can not see CID of other users. Or, this can be a bug... I have the same problem, by the way.
     
  4. habros

    Joined:
    Jul 25, 2012
    Messages:
    5
    Likes Received:
    0
    I cannot see my own CIDs after call passes que. If it's not only me who is affected than it's a bug as it breaks outlook and crm integration.
     
  5. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    check in the group rights, there is a new option, hide caller id from queues. disbale it and you will the the number as in V10
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. habros

    Joined:
    Jul 25, 2012
    Messages:
    5
    Likes Received:
    0
    Stefan,

    I see option for hiding CID under Extensions > [extention] > Other > 3CX MyPhone Options, however I cannot find the option that you are mentioning (for groups). Where is it?

    PS
    Changing CID hiding under Extensions does not make any difference.

    TIA
    Dave
     
  7. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    the right i am talking about is located in the group rights.
    click under ext on a group and you will see the rights of this group

    you can not set rights for the management group (sees by default everything) and non group members coz they simply dont have a group ;-)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. habros

    Joined:
    Jul 25, 2012
    Messages:
    5
    Likes Received:
    0
    Stefan,

    I had only MANAGEMENT group and as you mentioned and it did not have any settings available. I've created a new group with the permission enabled (unchecked) and add every extension to it. CID works now, thank you.

    Based on the info above, it seems that MANAGEMENT group has this setting "Hide CID..." disabled by default. Any way of editing some configuration file to change this behavior?

    TIA
    Dave
     
  9. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,210
    Likes Received:
    85
    by default all options are "enabled" for the MNG group.
    Did you used any Beta Versions of the V11 before the Final and uses the backup since?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. habros

    Joined:
    Jul 25, 2012
    Messages:
    5
    Likes Received:
    0
    Stefan,

    This a fresh install of the Windows Server and 3CX on Hyper-V.

    - Windows Server 2008 R2 Standard SP1 with all the updates and patches.
    - 3CX Phone System v11.0.26364.600.

    Dave
     
  11. LukaszW

    Joined:
    Jun 24, 2013
    Messages:
    1
    Likes Received:
    0
    Hi Stefan,

    Have you found a solution to that issue, please?

    I have just tried the same functionality and CID comes up on the phone and stays correct within 3cx but MyPhone shows a Private Number for all incoming calls.

    I checked the tick boxes you mentioned to "Hide Caller ID information in 3CX MyPhone" which are un-ticked (I only have one group anyway).

    Any suggestions much appreaciated.

    I am working on 3CX v11 with SP4 and Outlook 2013

    Thanks,
    Lukasz
     
Thread Status:
Not open for further replies.