3CX not changing status (DST issue?)

Discussion in '3CX Phone System - General' started by SVanBC, Mar 26, 2018.

  1. SVanBC

    Joined:
    Dec 14, 2017
    Messages:
    40
    Likes Received:
    1
    Hello

    As you may know we changed back to Summer Time few days ago. Todat I arrived at the office to see that my phones are all on DND mode. Timezone in the management console is set correctly (Belgium +1) and the server it's installed on, is correct aswel.
    I had to change the extension status to 'Available' manually, had to do the same with a customer of ours. Our lines should open up at 8:30 AM but as you can see at 8:32 (even right now probably if I didn't change it) they were still closed. The customers lines would open up at 8:00 AM but at 8:40 they were still closed. I've attached a few screenshots.

    This is the first time I need to do this; changing the statusses manually because the 3CX is failing somehow.

    Any ideas? Will this automatically be fixed or do I need to configure the office hours again?

    Thanks in advance
    [​IMG]

    [​IMG]

    [​IMG]
     
  2. richardwvm

    Joined:
    Dec 21, 2015
    Messages:
    27
    Likes Received:
    1
    Yes same here, looks like 3CX hasn't noticed the time on the server has changed.

    I just made everyone "Available" and will restart the services out of hours later.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Marco Dalli

    Joined:
    Mar 26, 2018
    Messages:
    2
    Likes Received:
    0
    Same here in Italy. I noticed that the Debian VM 3CX is running on reports the correct time and timezone (CEST), also 3CX itself can see the correct time (in the call log I can see incoming and outbound calls with the correct time).

    It would be good to hear something from 3CX.

    Marco
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,520
    Likes Received:
    240
    Hello,

    Please note that there have been other reports regarding this and we are currently investigating the issue. Can you please let me know your timezones and if your are on Linux or Windows. Also can you please check if the system will switch to out of office and let me know
     
  5. fonebox

    Joined:
    Dec 22, 2015
    Messages:
    9
    Likes Received:
    1
    Same issue in Ireland and UK
     
  6. WhiteN

    Joined:
    Nov 5, 2015
    Messages:
    5
    Likes Received:
    0
    Same issue here for CEST on Windows.
     
  7. Marco Dalli

    Joined:
    Mar 26, 2018
    Messages:
    2
    Likes Received:
    0
    I have disabled the settings and re-enabled only lunch time, and that works fine... I will check tonight if regular business hours work as well. To me, having only lunch time is fine, I can manage business hours globally.
     
  8. kenttec

    Joined:
    Jul 29, 2016
    Messages:
    57
    Likes Received:
    16
    Same, here, UK, Windows Server 2016 time correct on server. But 3CX office hours still out by 1 hour.
     
  9. fonebox

    Joined:
    Dec 22, 2015
    Messages:
    9
    Likes Received:
    1
    Hi all
    What work around have you implemented? Just changing the timezone of the 3CX within settings?

    How long do these type of issues typically take?

    Phil
     
  10. aws2p

    Joined:
    Jan 9, 2014
    Messages:
    22
    Likes Received:
    1
    Hi, for me same problem in France, i've just manually set the statut to available the firstime, after that all seems to become normal with automated time changes working fine
     
    fonebox likes this.
  11. Vahur

    Joined:
    Jan 20, 2017
    Messages:
    9
    Likes Received:
    0
    Same here: Estonia, GMT+2 DST, Professional Perpetual 15.5.0, Windows Server 2012 R2.