Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3cx only tcp voip provider

Discussion in '3CX Phone System - General' started by ImpLosioN, Oct 1, 2014.

Thread Status:
Not open for further replies.
  1. ImpLosioN

    Joined:
    Oct 1, 2014
    Messages:
    2
    Likes Received:
    0
    Hello,

    A VoIP provider can be successful only as TCP calls.
    How can I make a call just as TCP?

    Thanks.
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Hi there,
    You can try adding ;transport=Tcp after the host of provider, then apply (this is not a supported configuration).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ImpLosioN

    Joined:
    Oct 1, 2014
    Messages:
    2
    Likes Received:
    0
    Where add this?

    I add IP;transport failure?

    01-Eki-2014 15:53:39.634 Leg L:117955.1[Extn] is terminated: Cause: BYE from 192.168.19.31:50441
    01-Eki-2014 15:53:35.425 [CM503007]: Call(C:117955): Extn:192 has joined, contact <sip:192@192.168.19.31:50441>
    01-Eki-2014 15:53:35.422 L:117955.3[EndCall] has joined to L:117955.1[Extn]
    01-Eki-2014 15:53:35.313 [CM503025]: Call(C:117955): Calling T:EndCall:EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=90e4cb9371e23587] for L:117955.1[Extn]
    01-Eki-2014 15:53:35.305 L:117955.1[Extn] failed to reach Line:10005>>05552379265, reason Server Failure
    01-Eki-2014 15:53:35.305 Call to T:Line:10005>>05552379265@[Dev:sip:02164687602@84.44.127.6;transport=Tcp:5060] from L:117955.1[Extn] failed, cause: Cause: 503 Service Unavailable/INVITE from local
    01-Eki-2014 15:53:35.298 [CM503025]: Call(C:117955): Calling T:Line:10005>>05552379265@[Dev:sip:02164687602@84.44.127.6;transport=Tcp:5060] for L:117955.1[Extn]
    01-Eki-2014 15:53:35.273 [CM503027]: Call(C:117955): From: Extn:192 ("keremg" <sip:192@192.168.16.153:5060>) to T:Line:10005>>05552379265@[Dev:sip:02164687602@84.44.127.6;transport=Tcp:5060]
    01-Eki-2014 15:53:35.273 [CM503004]: Call(C:117955): Route 1: from L:117955.1[Extn] to T:Line:10005>>05552379265@[Dev:sip:02164687602@84.44.127.6;transport=Tcp:5060]
     
  4. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Yes apologizes this trick seems to not work anymore, the correct syntax from hostpart should be 84.44.127.6:5060;transport=Tcp but you can't manipulate the fields in this way apparently it will make it 84.44.127.6;transport=Tcp:5060 which is not valid.

    Therefore you will have to post this as a feature request on 3CX ideas : http://www.3cx.com/ideas/ there is no workaround at the moment on this matter.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. ozetto

    Joined:
    Apr 22, 2015
    Messages:
    4
    Likes Received:
    0
    Hi,

    I am having same issue.

    Is there any solution now about using only TCP with SIP Trunk?

    or

    Is there any option to set server mode or client mode for Sip Trunks?


    Thanks.
     
Thread Status:
Not open for further replies.