3cx outbound parameter with VOIP AXTEL conmigo in mexico

Discussion in '3CX Phone System - General' started by clonick, Sep 27, 2013.

Thread Status:
Not open for further replies.
  1. clonick

    Joined:
    Apr 19, 2012
    Messages:
    26
    Likes Received:
    0
    Hi,

    I was using succefull axtel conmigo voip service in mexico but after 5 months the outbound calls not work any more...
    I exactly not know what could be missing but here is the log:

    Code:
    17:32:59.292  Currently active calls - 1: [8]
    17:32:55.648  [CM503025]: Call(8): Calling VoIPline:89956042@(Ln.10005@axtel)@[Dev:sip:10002939670ip@mty15.axtel.net:5060]
    17:32:55.644  [MS210002] C:8.2:Offer provided. Connection(transcoding mode): 148.240.175.2:9030(9031)
    17:32:55.596  [CM503004]: Call(8): Route 1: VoIPline:89956041@(Ln.10005@axtel)@[Dev:sip:10002939670ip@mty15.axtel.net:5060]
    17:32:55.595  [CM503010]: Making route(s) to <sip:89956042@192.168.0.25>
    17:32:55.595  [MS210000] C:8.1:Offer received. RTP connection: 148.240.175.2:16314(16315)
    17:32:55.594  Remote SDP is set for legC:8.1
    17:32:55.594  [CM505001]: Ext.1050: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [LG-Nortel LIP 6804 v1.2.38sp SN/001A7EA573A1] PBX contact: [sip:1050@192.168.0.25:5060]
    17:32:55.592  [CM503001]: Call(8): Incoming call from Ext.1050 to <sip:89956042@192.168.0.25>
    17:32:55.586  [CM500002]: Info on incoming INVITE:
      INVITE sip:89956042@192.168.0.25 SIP/2.0
      Via: SIP/2.0/UDP 192.168.0.18:5060;rport=5060;branch=z9hG4bK-90e-236044-2619e5c8
      Max-Forwards: 70
      Contact: <sip:1050@148.240.175.2:5060>
      To: <sip:89956042@192.168.0.25>
      From: <sip:1050@192.168.0.25>;tag=94bed010-c0a80012-13c4-90e-332c098a-90e
      Call-ID: 94be32e8-c0a80012-13c4-90e-64a3ab0e-90e@192.168.0.25
      CSeq: 2 INVITE
      Proxy-Authorization: Digest username="Ext.1050",realm="3CXPhoneSystem",nonce="414d535c0856989741:cdb4304288734b6d3db2b083c3ba07b4",uri="sip:89956042@192.168.0.25",response="5866447afb96ac63145a8627369e41d2",algorithm=MD5
      Supported: replaces
      User-Agent: LG-Nortel LIP 6804 v1.2.38sp SN/001A7EA573A1
      Content-Length: 0
    Glosary:
    89956042 -is the phone number where I try to call
    192.168.0.25 -is the local ip of 3cx
    1050 -is the extension where is calling the phone number
    148.240.175.2 -is the public ip of the 3cx (firewall was passed in 3cx, all ports forward to 3cx in router for debug)
    10002939670ip -SIP user id of the voip axtel
    mty15.axtel.net -host of voip provider axtel, they also uses same host as outbound proxy


    i was seeing error of timeout request and or 420 and 480...

    I think is a wrong outbound parameter in the config of the voip trunk axtel in 3cx, but i don't know what parameter... any ideas?

    thanks......
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. clonick

    Joined:
    Apr 19, 2012
    Messages:
    26
    Likes Received:
    0
    Please help! Or any idea to debug!?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    The log doesn't show any indication of an error, it appears that the call completes properly. What do you get when you place a call? Silence? A recording?

    The only clue might be this..
    Which may indicate that the Codec(s) that you are allowing 3CX to use don't match those used by your Provider. setting the logs to Verbose will give you more information about the call, perhaps enough to troubleshoot.
    Have you spoken to your provider about any changes that they may have made recently? if you can narrow down to the day it stopped working that might help them "remember" any changes that they recently implemented.
     
  4. clonick

    Joined:
    Apr 19, 2012
    Messages:
    26
    Likes Received:
    0
    Hi leejor,

    I hang up the 1050 extension an call directly the phone number 89956042 and I recibe dial tone next when key the phone I don't recive any voice or sound or nothing.

    I'm talking with the voip provider right now, hope they can give some answer; at this point I know voip provider uses speex and G729a as codec.

    Code:
    15:52:46.076  Currently active calls [none]
    15:52:46.023  [CM503020]: Normal call termination. Reason: No answer
    15:52:46.023  [CM503016]: Call(13): Attempt to reach <sip:89956042@192.168.0.25> failed. Reason: No Answer
    15:52:46.020  [CM503003]: Call(13): Call to sip:89956042@mty1.axtel.net:5060 has failed; Cause: 408 Request Timeout; from IP:207.249.182.154:5060
    15:52:14.075  Currently active calls - 1: [13]
    15:52:13.800  [CM503025]: Call(13): Calling VoIPline:89956042@(Ln.10005@axtel)@[Dev:sip:10002939670ip@mty15.axtel.net:5060]
    15:52:13.797  [MS210002] C:13.2:Offer provided. Connection(transcoding mode): 148.240.175.2:9040(9041)
    15:52:13.612  [CM503004]: Call(13): Route 1: VoIPline:89956042@(Ln.10005@axtel)@[Dev:sip:10002939670ip@mty15.axtel.net:5060]
    15:52:13.612  [CM503010]: Making route(s) to <sip:89956042@192.168.0.25>
    15:52:13.612  [MS210000] C:13.1:Offer received. RTP connection: 148.240.175.2:16308(16309)
    15:52:13.610  Remote SDP is set for legC:13.1
    15:52:13.609  [CM505001]: Ext.1050: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [LG-Nortel LIP 6804 v1.2.38sp SN/001A7EA573A1] PBX contact: [sip:1050@192.168.0.25:5060]
    15:52:13.608  [CM503001]: Call(13): Incoming call from Ext.1050 to <sip:89956042@192.168.0.25>
    15:52:13.602  [CM500002]: Info on incoming INVITE:
      INVITE sip:89956042@192.168.0.25 SIP/2.0
      Via: SIP/2.0/UDP 192.168.0.18:5060;rport=5060;branch=z9hG4bK-7da6a-1ead308c-482628a9
      Max-Forwards: 70
      Contact: <sip:1050@148.240.175.2:5060>
      To: <sip:89956042@192.168.0.25>
      From: <sip:1050@192.168.0.25>;tag=94bedf60-c0a80012-13c4-7da6a-50555953-7da6a
      Call-ID: 94be1f08-c0a80012-13c4-7da6a-fb95b22-7da6a@192.168.0.25
      CSeq: 2 INVITE
      Proxy-Authorization: Digest username="Ext.1050",realm="3CXPhoneSystem",nonce="414d535c085e69fd37:9c46e8081ae6a4d463e28c7f81b7b01f",uri="sip:89956041@192.168.0.25",response="f128b324b48abfe19a3506458f429733",algorithm=MD5
      Supported: replaces
      User-Agent: LG-Nortel LIP 6804 v1.2.38sp SN/001A7EA573A1
      Content-Length: 0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    I would experiment with the Codec settings in the 3CX trunk parameters for this provider. If you set the log to Verbose, I believe it will show you which Codec is being used or attempted.

    Unless you have an issue with bandwidth, I would stick with G711A and G711U only. You can try using one at a time, or put all of them in there. Some may not be available in 3CX for licensing reasons.
     
  6. clonick

    Joined:
    Apr 19, 2012
    Messages:
    26
    Likes Received:
    0
    Hi leejor,

    The point here is that is selected verbose mode in pbx, so the log posted is in verbose mode!
    Also the codec selected are all available and when it was working, all the codecs was selected too.

    My bandwidth is 20mbps symmetric by fiber optic. 5ms ping to my voip provider.

    I think the problem could be:
    15:52:46.020 [CM503003]: Call(13): Call to sip:89956042@mty1.axtel.net:5060 has failed; Cause: 408 Request Timeout; from IP:207.249.182.154:5060

    But i ping that ip and portand it respond!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    Are you able to receive calls from the provider?

    The Timeout could be a number of reasons...

    The provider does not have the correct IP to send a response to. Possible STUN issue?

    Your router/firewall is blocking the response. I assume that the 3CX firewall check passes.

    You provider has changed their settings and requires that outgoing calls are directed to a different URL/ outbound proxy.


    I would contact the provider and see if any changes were made about the time your outbound calls started failing. Some providers will even monitor your attempted call to help diagnose exactly what is going on.

    You may want to make use of Wireshark to see if there is an acknowledgement of any sort, from the provider, of your outbound call attempt
     
  8. clonick

    Joined:
    Apr 19, 2012
    Messages:
    26
    Likes Received:
    0
    Hi leejor,

    Yes, i'm able to make calls with my voip provider.
    In the case that be the timeout, how i could debug it? I mean with the software of the company for voip makes call very fast, so i think is in the range of timeout.

    Maybe the issue is the correct ip to response, or an outbound parameter but how to debug for know the issue and how to fix it, i modify some values for know if something changes and not. How i can test if stun server is working in the 3cx?

    I will check twice about the router blocking ports because could be possible but 3cx shows firewall pass in all points.

    Let me check. Thanka leejor
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.