3cx over VPN

Discussion in '3CX Phone System - General' started by radix, Feb 5, 2009.

Thread Status:
Not open for further replies.
  1. radix

    Joined:
    Feb 5, 2008
    Messages:
    23
    Likes Received:
    0
    I have problems with the audio when calling over VPN.

    First my config:

    3cx 7.4744
    patton 4554 ISDN
    3cx clients 7.0.4526
    clients os: Vista 32, 64

    When all the clients are connected to our local network everything works ok ( ext<->ext, ext<->out)
    Sometimes we work from home so we connect over VPN to our office network.
    In this case the 3cx client register over VPN to the 3cx and I can call other extensions and everything works ok. (ext<->ext)
    If I get an call over the patton (ISDN), the client get the call, the connection is made, but no voice is transmitted either way. (ext<->out)

    Anyone have an ideea why this could happen and how could I fix it?

    Thanks

    P.S. i have an comercial version with support but somehow I like more the support from the forum :)
     
  2. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    Has your Patton got the default gateway configured in it's IP stack which corresponds to the route via which you want to send VPN packets?
    (i.e. if your VPN endpoint on the LAN in the office isn't the same device/IP address as the default gateway, you will need to stick a static route into the gateway for the remote LANs)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. radix

    Joined:
    Feb 5, 2008
    Messages:
    23
    Likes Received:
    0
    HI

    Thanks for the ideea. I've looked in the patton and I've seen that there is no option to set the default gateway so I just added a route for the ip range of the VPN connections and now everything works nice.

    Thanks again!
     
Thread Status:
Not open for further replies.