3cx, Patton 4114 FXO, and Axis A8105

Discussion in '3CX Phone System - General' started by sipnewbie, Sep 28, 2017.

Thread Status:
Not open for further replies.
  1. sipnewbie

    Sep 28, 2017
    Likes Received:
    3cx PBX 15.5.5
    Patton 4114 FXO R6.T 2017-05-08
    Axis A8105-E Door Station 1.65.1
    pfSense 2.3.4_1
    iPhone 3cx client

    3cx, Patton with FX0 connected to PSTN, and Axis are on the same subnet. 3cx firewall tests all good. Generated the Patton config and applied it successfully from 3cx. Seemingly, I've configured everything properly per all the guides, how-tos, etc., and all the lights are green....

    But, it doesn't perform consistently. I'm reasonably certain it's an RTP port issue, but can't find the correct range of ports to open or configure. 9000-9500 are forwarded in pfSense. Default RTP start is 4000 for Axis, and the 3cx iPhone client, 4864-5375 for Patton. I've set them all the same, I've defaulted them, I've looked and applied the 3cx parameter config FIRSTPORT-LASTPORT, to them, etc.

    When all calls are local (within the LAN), Axis <> 3cx <> iPhone client, voice works both ways. I can call Axis, and Axis can call the 3cx iPhone client on WiFi.

    Problem Symptom1: No change, other than than the iPhone is now on LTE, rather than WiFi, tried both with and without the 3cx Tunnel. I can still call Axis, and Axis can still call me, but voice is one-way. I can hear the Axis microphone.

    Problem Symptom2: Drop the 3cx/iPhone connection and force the call to be routed via PSTN to my iPhone. Voice is one-way. I can hear the Axis microphone.

    Anybody have a little insight or direction?
Thread Status:
Not open for further replies.