Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX PBX Debian 8 install

Discussion in '3CX Phone System - General' started by toxicfusion, Dec 14, 2016.

Thread Status:
Not open for further replies.
  1. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
    Hello,

    Trying to install 3CX Free version for testing.

    VPS - Debian 8 86_64bit install

    apt-get update && apt-get upgrade

    I then follow the 3CX debian install guide.. FAILS

    dpkg: error processing package 3cxpbx (--configure):
    subprocess installed post-installation script returned error exit status 139
    Errors were encountered while processing:
    3cxpbx
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@debian:~#


    What is the cause here?
     
  2. Azuroth

    Joined:
    Oct 22, 2015
    Messages:
    6
    Likes Received:
    0
    I'm going to guess that you have tried running it under sudo correct ?
     
  3. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
    Indeed, however no need when accessing as root.
     
  4. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
    was the apt source list updated to the new 15 sp4 package?
     
  5. andreasc

    andreasc Guest

    Hi toxicfusion

    Please run the following commands
    apt-get install virt-what
    virt-what

    and let me know what will show you?
     
  6. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
  7. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
    here is some more output of the error on install (Option 1)

    dpkg: error processing package 3cxpbx (--configure):
    subprocess installed post-installation script returned error exit status 139
    Errors were encountered while processing:
    3cxpbx
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    W: Operation was interrupted before it could finish
     
  8. andreasc

    andreasc Guest

    Hi toxicfusion,

    Can you try uninstalling and installing the PBX
    by run the following commands.

    apt purge 3cxpbx
    apt-get autoremove
    apt update
    apt install 3cxpbx

    let me know it that worked for you.
     
  9. toxicfusion

    Joined:
    Dec 14, 2016
    Messages:
    6
    Likes Received:
    0
    Same.. For record I ran all those above commands prior to posting on forum. Also reloaded the VPS with fresh install of Debian 8

    uname output:

    Linux debian 4.8.3-x86_64 #1 SMP Thu Oct 20 19:05:39 EDT 2016 x86_64 GNU/Linux


    dpkg: error processing package 3cxpbx (--configure):
    subprocess installed post-installation script returned error exit status 139
    Processing triggers for libc-bin (2.19-18+deb8u6) ...
    Errors were encountered while processing:
    3cxpbx
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  10. andreasc

    andreasc Guest

  11. cirrus

    Joined:
    Jun 1, 2009
    Messages:
    1
    Likes Received:
    0
    Fresh Debian 8 install on Linode fails with the same error as the OP.

    uname -a output:
    Linux localhost 4.9.15-x86_64-linode81 #1 SMP Fri Mar 17 09:47:36 EDT 2017 x86_64 GNU/Linux

    install output:
    dpkg: error processing package 3cxpbx (--configure):
    subprocess installed post-installation script returned error exit status 139

    FIX: Instead of running the Linode's kernel, use the distribution supplied kernel by editing the configuration profile "My Debian 8 Profile" on Linode and selecting GRUB 2. Reboot and re-install should be successful. (3CX is not compatible with v4 kernels?)

    Distribution supplied kernel uname output:
    Linux localhost 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u1 (2017-02-22) x86_64 GNU/Linux
     
    #11 cirrus, Jun 10, 2017
    Last edited: Jun 10, 2017
Thread Status:
Not open for further replies.