3CX phone always 'new' under Phones?

Discussion in 'Windows' started by PatrickTodd, Apr 12, 2016.

Thread Status:
Not open for further replies.
  1. PatrickTodd

    Joined:
    Jan 12, 2016
    Messages:
    40
    Likes Received:
    5
    I'm using V14 sp3 and distributed 3cx via the Welcome emails.

    For some reason, no matter how many times I rightclick assign the softphones they always show up later as 'new'. They seem to work ok with the imported provisioning file but the server interface never remembers what extension they are.

    Is this intended or is it a common issue I somehow looked over / misconfigured? What can I province to resolve this?
     
  2. hardywo

    Joined:
    Mar 22, 2016
    Messages:
    11
    Likes Received:
    0
    Hi Patrick,

    I have the same issue in my installation of 3CX so am joining this thread to hear if anyone has any solutions.

    Bill
     
  3. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    41
    Likes Received:
    0
    Same here, sort of. I never assigned them to any extension, because I was not sure if this was something I needed to do. After installing the client software, and adding the configuration file, everything works fine, as it should. But when I go into the Phones module, the clients all show up "new". I'm reluctant to assign anything, since it does work, but wish I could find more information on what's going on with this process, and if it is supposed to look this way by design.
     
  4. lloydr1l

    Joined:
    Dec 18, 2015
    Messages:
    41
    Likes Received:
    0
    So I asked 3CX Support about this behavior, and at least in my case the explanation was very good and gave me a clearer understanding of why this happens. There are two responses I will post here with permission from 3CX Support, the first for my original question about this subject, and the second a clarification of what happens if I "reject".

    This from Nick, a Senior Support Engineer:

    Original Reply

    This could happen, but let me explain in a bit more detail. Like most supported deskphones do when you plug them into the same network where 3CX Phone System is installed, when you install a 3CXPhone app it will show up in the Management Console under "Phones" as the deskphones. Now if you send a Welcome Email to provision one of the 3CXPhone applications, once a user double-clicks the provisioning file, the settings will be loaded into the 3CXPhone app but it will first go into CTI mode. At this point this endpoint will still remain as bold in the "Phones" node until you switch the 3CXPhone into softphone mode (not CTI).

    Another scenario in which this could happen is if you install 3CXPhone on a PC on the network which will cause it to show up in the Management Console, but then before using a provisioning file, the PC changes IPs, then you provision the 3CXPhone, this will cause the bold entry to stay there as it appeared when the PC had the initial IP.

    Regardless however, if every endpoint is working as intended, if you want you can purge the bold entries without affecting the functionality of the Phone System in any way. To do this all you have to do is go to the "Phones" node, select all the bold entries (you can use the Shift key to select multiple entries) and then press the "Reject" button.


    Follow-Up

    If the reject anything in the "Phones" node, it will always come back if you launch the 3CXPhone app again and it does not have an account on launch. The same applies for deskphones, if you reject them, but them restart them, if they do not have an account registered in them they will reappear in the list, as long as they are on the same network as the 3CX Phone System server of course.

    When it comes to 3CXPhone apps however, even if they are not in the list as bold, you can always send a Welcome Email regardless and provision them that way.


    Hope this helps someone. It did me.
     
  5. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    Indeed, I regularly (twice a month..ish) look at the Phones to assign the ones I can match, and whatever is left I reject.
    They multicast to the host at some point.. usually by the time I see it then somebody logged into some other workstation they don't usually use.. and subsequently didn't care about the 3CX config.. or didn't yet open the welcome email attachment to provision. The result is the same.. rejecting them after the fact will take the garbage out.. until more phones cast back in. They don't ever go away unless I reject or assign.. and even an assign may not make them go away. ;)
     
Thread Status:
Not open for further replies.