3cx phone disco after call

Discussion in 'Windows' started by Omoks, Apr 8, 2015.

Thread Status:
Not open for further replies.
  1. Omoks

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0
    Good day,

    I'm trying to troubleshoot why in my contact center for a random number of agents and some to be fair less random keep getting disconnected from the 3cx softphone for windows after calls.

    It's not consistent but there are certain observations, it happens more in the evening and when it does it happens back to back.

    Here's part of the debug

    Sound mic device OK []
    Sound ring device OK []
    Sound speaker device OK []
    Sending STUN request
    Sending STUN request
    STUN check failed
    Phone is now connected

    Video stream will be received on xxx.xxx.xxx.xxx
    Phone has been disconnected - error: 403
    Phone is no longer connected
    Phone connection failed, PBX not responding


    Usually a restart of the phone fixes this. I'm not loosing any internet connection on the user(s) system. And it just seems to happen to some users more than others

    Any ideas? Is there a recommended rtp timeout I can put in the PBX or am I looking in the wrong direction.

    Thanks
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Hi there,
    Can you clarify which version of 3CXPhone and which of 3CX phone system are you running?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Omoks

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0

    Sure. Most recent version of 3CX phone for windows with a 3cx pbx portal. It gets a bit complicated but there's Voip media gateway by Patton for DIDs but thats a different story.
     
  4. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Can you confirm that if you are running antivirus or proxy on the client machine it has been configured according to : http://www.3cx.com/blog/docs/3cxphone-presence-self-help/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Omoks

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0
    You know what. I haven't done that yet. My company has a firewall so all my PC's use AVG with all firewall functions disabled. When I get in tonight I'll try this and let you know. Thanks
     
  6. Omoks

    Joined:
    Apr 8, 2015
    Messages:
    5
    Likes Received:
    0

    Okay! So I verified my corporate AVG settings with those in the link. Good thing is that all features of the AVG application except file scanning are enabled. In essence it does no LAN/ WAN or firewall functionality other than scanning files.


    What else could be wrong. This issue doesn't seem to have a pattern in that it happens every day. Different people but I can't recreate it. But then again if I could i guess then I'd know what the cause was.
     
Thread Status:
Not open for further replies.