3cx Phone DTMF echo

Discussion in 'Windows' started by pstulac, Sep 21, 2011.

Thread Status:
Not open for further replies.
  1. pstulac

    Joined:
    Jul 8, 2011
    Messages:
    21
    Likes Received:
    0
    Recently I have noticed major issues with dtmf on 3cx Phone. When doing some wireshark captures on one of the machines I noticed that 3CX phone is echoing the digits multiple times and this can be repeated on various machines. When testing with XLite on the same machine(s) this doesn't occur with repeated testing. Anyone got any ideas on what I can do to remedy this?

    None of my Hardphones exibit the same issue and as I said Xlite works fine, I have tested using G711U and GSM as well as with 2833 and inband dtmf.
     
  2. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Could you please provide a wireshark capture which shows this problem?

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,726
    Likes Received:
    275
    Try changing (playing with) the DTMF settings in the phone. Whatever device/provider is at the other end may be happy with one type of DTMF (method) and I suspect that you are sending more than one type, audio being one of them.
     
  4. pstulac

    Joined:
    Jul 8, 2011
    Messages:
    21
    Likes Received:
    0
    Unfortunately did that already without much luck.
     
  5. pstulac

    Joined:
    Jul 8, 2011
    Messages:
    21
    Likes Received:
    0
    It's not on the Iphone that the problem exists, its on the windows version. Any other softphone I or other users use works fine, so at this point we've stopped using 3cxphone.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,726
    Likes Received:
    275
    Did you ever provide Stepan with a Wireshark capture as he requested?

    You don't say if this is happening on outside calls only (I'm going to assume so) , and if so, do you use a gateway or VoIP provider?

    Some users will get multiple DTMF digits because they are sending the audio DTMF as well as a SIP message telling the gateway to generate a tone (which can sometimes be heard by the caller), so it sounds like you are sending double digits.

    Since this is not happening in all of your devices, it is probably a incompatibility, in DTMF settings between your gateway and the 3CX windows phone.
     
Thread Status:
Not open for further replies.