3CX Phone V8 Wont Open

Discussion in 'Windows' started by 2evolve, Nov 19, 2014.

Thread Status:
Not open for further replies.
  1. 2evolve

    Joined:
    Jan 23, 2009
    Messages:
    21
    Likes Received:
    0
    I have a client that has a brand new Dell M6500. Initially the 3CX Phone installed and was working great then they installed some logitech drivers and now the program wont open.

    I uninstalled the Logitech drivers but the issue persists, uninstalled the 3CX Phone, rebooted and re-installed but the issues persists. Uninstalled (renamed folder in C:\Program Dataz) and rebooted carried out clean install but same issues persists.

    When opening the program the process starts in task managed loads about 4mb of RAM with very little read/write then just stalls.

    Anyone have any ideas to resolve this? I can install 3CX Phone v6 on the machine so the user can make calls etc but cannot visualise the presence information that is in V8 due to myphone dissappearing.

    Any help would be greatly appreciated.

    2e-volve.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    646
    Likes Received:
    1
    Hi,
    I'm not sure if those drivers are in cause, can you check your network adapters and disable any that is not required by communication between 3CXPhone and PBX and see if issue persists after restarting 3CXPhone?
    Also, please try the following, stop 3CXPhone, go in explorer, browse to %appdata%\3CXPhone for Windows\, delete or rename file 3CXPhone.xml, restart 3CXPhone, it should start clear of any profile/settings, awaiting for provisioning.
    What OS are you running by the way ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. 2evolve

    Joined:
    Jan 23, 2009
    Messages:
    21
    Likes Received:
    0
    Hi there appreciate your reply,

    Network adapters are unchanged from when it was working but disabled the non-essential ones.

    I had already renamed the 3cx config.xml file but tried again.

    I've copied below the log from the last run of the 3CX Phone, quite a few errors but not sure how to get rid of them:

    Code:
    [20.11.2014 15:36:54.746][1] DialPad loaded
    [20.11.2014 15:36:54.813][1] Initializing notify icon
    [20.11.2014 17:11:24.801][1] Starting application
    [20.11.2014 17:11:24.804][1] Initializing configuration
    [20.11.2014 17:11:24.871][1] Loading configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml
    [20.11.2014 17:11:24.872][1] Initializing configuration with existing xml configuration
    [24.11.2014 12:46:19.232][1] Error occurred when initializing Plantronics headset support: Failed to connect to Spokes
    [24.11.2014 12:46:19.242][1] Initializing supported languages dictionary
    [24.11.2014 12:46:19.302][1] Merging string resource dictionary
    [24.11.2014 12:46:19.462][1] Opening named pipe for IPC
    [24.11.2014 12:46:19.562][1] Cannot load CRMPlugin: Could not load file or assembly 'CallNotifier' or one of its dependencies. The system cannot find the file specified.
    [24.11.2014 12:46:19.562][1] Cannot load CRMPlugin: Could not load file or assembly 'CallNotifierOutlook' or one of its dependencies. The system cannot find the file specified.
    [24.11.2014 12:46:19.772][1] Targets override Demo, Standard, Pro 3CXPhoneTapiPlugin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bac47dd19dc4098a
    [24.11.2014 12:46:19.772][1] Pro added 3CXPhoneTapiPlugin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bac47dd19dc4098a
    [24.11.2014 12:46:19.772][1] Std added 3CXPhoneTapiPlugin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bac47dd19dc4098a
    [24.11.2014 12:46:19.772][1] Demo added 3CXPhoneTapiPlugin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=bac47dd19dc4098a
    [24.11.2014 12:46:19.792][1] Pro only added CallTriggerCmdPlugin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
    [24.11.2014 12:46:19.812][1] Initializing main window
    [24.11.2014 12:46:19.862][1] Client version 12.0.37098.0
    [24.11.2014 12:46:20.542][1] MainWindow activated
    [24.11.2014 12:46:20.632][1] Loading main window
    [24.11.2014 12:46:20.642][1] Starting sound manager
    [24.11.2014 12:46:21.432][1] Biz Init start
    [24.11.2014 12:46:21.433][1] Performing email provisioning
    [24.11.2014 12:46:21.536][1] ********************** SIPInitialize 0
    [24.11.2014 12:46:21.541][1] ********* inited media with echoCancellationEnabled=1 (tail len 500), vadEnabled=0, userAgent='3CXPhone for Windows 12.0.37098.0'
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-pjsua-log" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-tsx-layer" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-stateful-util" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-ua" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-100rel" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-pjsua" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541 sip_endpoint.c  .Module "mod-invite" registered
    
    [24.11.2014 12:46:21.541][1] 12:46:21.541          pjlib  ..select() I/O Queue created (0A00F6A4)
    
    [24.11.2014 12:46:21.543][1] 12:46:21.543    pjsua_vid.c  ..Initializing video subsystem..
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-evsub" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-presence" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-mwi" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-refer" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-pjsua-pres" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-pjsua-im" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 sip_endpoint.c  .Module "mod-pjsua-options" registered
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547   pjsua_core.c  .1 SIP worker threads created
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547   pjsua_core.c  .pjsua version 2.1 for win32-6.1/i386/msvc-16.0 initialized
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547   pjsua_core.c  .PJSUA state changed: CREATED --> INIT
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 wmme_dev_3cx.c  wmme refresh start
    
    [24.11.2014 12:46:21.547][1] 12:46:21.547 wmme_dev_3cx.c  wmme refresh 20
    
    [24.11.2014 12:46:21.565][1] 12:46:21.565 wmme_dev_3cx.c  wmme refresh 30
    
    [24.11.2014 12:46:21.565][1] 12:46:21.565 wmme_dev_3cx.c  wmme refresh 40
    
    [24.11.2014 12:46:21.565][1] 12:46:21.565 wmme_dev_3cx.c  wmme refresh 50
    
    [24.11.2014 12:46:21.567][1] 12:46:21.567 wmme_dev_3cx.c  wmme refresh 60
    
    [24.11.2014 12:46:21.571][1] 12:46:21.571 wmme_dev_3cx.c  wmme refresh before get_dev_names
    
    [24.11.2014 12:46:21.571][1] 12:46:21.571 wmme_dev_3cx.c  get_dev_names 10
    
    [24.11.2014 12:46:21.572][1] 12:46:21.572 wmme_dev_3cx.c  get_dev_names 12 -2147417850
    
    [24.11.2014 12:46:21.572][1] 12:46:21.572 wmme_dev_3cx.c  get_dev_names 14 1
    
    [24.11.2014 12:46:21.572][1] 12:46:21.572 wmme_dev_3cx.c  get_dev_names 20 0
    
    [24.11.2014 12:46:21.572][1] 12:46:21.572 wmme_dev_3cx.c  get_dev_names 30 0
    
    [24.11.2014 12:46:21.572][1] 12:46:21.572 wmme_dev_3cx.c  get_dev_names 40 0 5
    
    [24.11.2014 12:46:21.576][1] 12:46:21.576 wmme_dev_3cx.c  get_dev_names success
    
    [24.11.2014 12:46:21.577][1] 12:46:21.576 wmme_dev_3cx.c  WMME! found 6 devices:
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 0: Primary Sound Driver  (in=2, out=2)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 1: Microphone (Orbit/Sphere AF)  (in=2, out=0)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 2: Headset Microphone (Bluetooth Hands-free Audio)  (in=2, out=0)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 3: Headphones (Bluetooth Hands-free Audio)  (in=0, out=2)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 4: Speakers / Headphones (IDT High Definition Audio CODEC)  (in=0, out=2)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c   dev_id 5: Independent (R.T.C.) Headphones (IDT High Definition Audio CODEC  (in=0, out=2)
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 wmme_dev_3cx.c  WMME initialized
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577     PjsipUtils  in InitRingbackPort
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577     PjsipUtils  InitRingbackPort - success
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 desktop_dev.cp  Desktop video src initialized with 3 device(s):
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 desktop_dev.cp   0: Screen 1
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 desktop_dev.cp   1: Screen 2
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577 desktop_dev.cp   2: Screen 3
    
    [24.11.2014 12:46:21.577][1] 12:46:21.577    dshow_dev.c  Failed initializing DShow: COM library already initialized with incompatible concurrency model
    
    [24.11.2014 12:46:21.606][1] 12:46:21.606    dshow_dev.c  DShow has 1 devices:
    
    [24.11.2014 12:46:21.606][1] 12:46:21.606    dshow_dev.c   dev_id 0: QuickCam Orbit/Sphere AF (capture)
    
    [24.11.2014 12:46:21.622][1] 12:46:21.622   bitmap_dev.c  SDL 2.0 initialized
    
    [24.11.2014 12:46:21.623][1] 12:46:21.623 sip_transport_  pj_sock_bind: status = 0
    
    [24.11.2014 12:46:21.627][1] 12:46:21.627   tcplis:61559  SIP TCP listener ready for incoming connections at 192.168.100.41:61559
    
    [24.11.2014 12:46:21.627][1] created TCP transport on port 61559
    [24.11.2014 12:46:21.631][1] 12:46:21.631   pjsua_core.c  SIP UDP socket reachable at 192.168.100.41:61559
    
    [24.11.2014 12:46:21.631][1] 12:46:21.631    udp0B48D900  SIP UDP transport started, published address is 192.168.100.41:61559
    
    [24.11.2014 12:46:21.631][1] created UDP transport on port 61559
    [24.11.2014 12:46:21.632][1] Creating TLS transport
    [24.11.2014 12:46:21.636][1] 12:46:21.636   tlslis:61560  SIP TLS listener is ready for incoming connections at 192.168.100.41:61560
    
    [24.11.2014 12:46:21.636][1] created TLS transport on port 61560
    [24.11.2014 12:46:21.636][1] 12:46:21.636   pjsua_core.c  PJSUA state changed: INIT --> STARTING
    
    [24.11.2014 12:46:21.636][1] 12:46:21.636 sip_endpoint.c  .Module "mod-unsolicited-mwi" registered
    
    [24.11.2014 12:46:21.636][1] 12:46:21.636   pjsua_core.c  .PJSUA state changed: STARTING --> RUNNING
    
    [24.11.2014 12:46:21.636][1] Have capture device: 1, have playback device: 1
    [24.11.2014 12:47:29.443][1] Starting application
    [24.11.2014 12:47:29.446][1] Initializing configuration
    [24.11.2014 12:47:29.597][1] Loading configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml
    [24.11.2014 12:47:29.605][1] Initializing configuration with existing xml configuration
    [24.11.2014 16:26:05.094][1] Starting application
    [24.11.2014 16:26:05.096][1] Initializing configuration
    [24.11.2014 16:26:05.117][1] Loading configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml
    [24.11.2014 16:26:05.117][1] Configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml does'not exist
    [24.11.2014 16:26:05.117][1] Trying to load backup configuration
    [24.11.2014 16:26:05.117][1] Loading configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml.back
    [24.11.2014 16:26:05.118][1] Initializing configuration with existing xml configuration
    Thanks again for your help!

    Brian
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,429
    Likes Received:
    279
    I have not had this issue - but have you tried removing the config and backup config both?

    [24.11.2014 16:26:05.117][1] Loading configuration file C:\Users\david\AppData\Roaming\3CXPhone for Windows\3CXPhone.xml.back
    [24.11.2014 16:26:05.118][1] Initializing configuration with existing xml configuration
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. 2evolve

    Joined:
    Jan 23, 2009
    Messages:
    21
    Likes Received:
    0
    Thanks again for reply,

    Will try this and report back.

    Brian
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. norekhov

    3CX Support

    Joined:
    Jan 31, 2014
    Messages:
    53
    Likes Received:
    1
    Hello!

    You have no significant errors in your logs. Actually it's not erros - just a warnings to developers.

    Since your log doesn't end with a managed exception, you should see an exception in your windows event log. Please, check it there and let me know. If it's there, please send me an info from event.

    What drivers are you installed?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. 2evolve

    Joined:
    Jan 23, 2009
    Messages:
    21
    Likes Received:
    0
    Reviewed the first 3CX Log i sent in and noticed the errors relating to the plantronics software not being able to find its "Spokes"

    Uninstalled the Plantronics software then 3CX opened without an issue, re-install of the Plantronics software and both are talking to each other again.

    Issue is now resolved, thanks for your help!

    Brian
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.