Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3cx PhoneSystem Nginx Server not starting

Discussion in '3CX Phone System - General' started by Serhiy, Jan 14, 2019.

  1. Serhiy

    Joined:
    Oct 25, 2017
    Messages:
    21
    Likes Received:
    0
    Hi,
    I have issue with 3cx PhoneSystem Nginx Server, it`s not starting after reboot the server.
    Also service is not start after reboot with automatically up and when you try to load service manually. (screenshot attached in Russian Language)
    Screenshot translate -
    Can`t load 3cx PhoneSystem Nginx Server service on WIN-10RL1PU90EI.

    Error 1067: Process suddenly killed.


    In nginx error log in path - C:\Program Files\3CX Phone System\Bin\nginx\logs\error

    When I`m start service it`s added :
    2019/01/14 17:37:01 [emerg] 5932#4316: WSASocketW() failed (10044: The support for the specified socket type does not exist in this address family)

    Our license is Pro 15
    OS server is Windows Server 2008 R2 Standart.

    Please help us to resolve this issue.
    Thank you
     

    Attached Files:

  2. Marari

    Marari Member

    Joined:
    Sep 16, 2007
    Messages:
    283
    Likes Received:
    66
    @Serhiy

    Please indicate your full version (15.5 SP6? )
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Serhiy

    Joined:
    Oct 25, 2017
    Messages:
    21
    Likes Received:
    0
    Hi
    I` guess it`s 15_5 SP1
     
  4. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,773
    Likes Received:
    278
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,783
    Likes Received:
    564
    As mentioned try to upgrade your PBX to the latest stable version first and see if that resolves your issue. You may way want perform a backup before upgrading though. You can use the method outlined in the following guide. https://www.3cx.com/docs/backup-restore-command-line/