3CX registering remote internal IPs only

Discussion in '3CX Phone System - General' started by tpaulas, Oct 28, 2009.

Thread Status:
Not open for further replies.
  1. tpaulas

    Joined:
    Oct 27, 2009
    Messages:
    2
    Likes Received:
    0
    Hello all,

    I tried to solve this last two day without any luck. I will appreciate if someone can guide me and help me.
    I have 3CX server in DMZ zone at work. All needed ports are opened. Local network at work functioning OK.
    VOIP providers functioning OK. Everything is as it should be.

    If I try to connect from other location, where router (out : some public IP, in: 192.168.1.1) is installed and giving local IP 192.168.1.36 to C470IP phone using DHCP, phone will register sucessfuly and I see extension green on 3CX.

    Everything seems to work, until I try to make a call.
    When I try to make a call to my mobile, 3CX recognizes I'm calling, transfer it to VOIP provider and my mobile rings, BUT I can't hear anything after picking it up.
    Moreover, I can't hear any sound in C470IP phone either, even ringing sound.

    Almost same situation is with incoming calls. I have registered DND from my VOIP provider. If I call from my mobile to C470IP, 3CX tranfers a call to my device, but not ringing at all and silence on mobile as well.

    I went through Activity log of 3CX and see, that my C470IP phone is registered as :
    [sip:118@192.168.1.36:5060/118]

    I also see this result after making a call :

    [No RTP packets were received:remoteAddr=192.168.1.36:5004,extAddr=0.0.0.0:0,localAddr=195.122.xxx.xxx:9010]

    I understand, if 3CX is sending a call to 192.168.1.36 it is clear it can not be reached, because this IP is local IP in remote network. Shouldn't be here public IP of remote network, so 3CX can forward these calls there and remote router/NAT will then forward it to 192.168.1.36 ?

    If this conclusion is true, don't you know how to force C470IP register with public IP of a router/NAT instead of it's local IP in remote network ?

    Thank you very much, any help will be greatly appreciated.

    Regards Tomas
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Haven't used the C4701 myself but most VoIP phones have a STUN setting. Datafill with a STUN server (you can use the 3VC server or any other open STUN server) and then enable it. This should be done on any remote extension.

    Some routers can cause problem, and that could be the case with the one at the remote end. Have a look at the 3CX logs after you have enabled STUN on the extension, restart the extension and make sure that 3CX is seeing the set register with the public IP and port, not the private one. Also check to make sure that no other device on the remote network is using the same port assigned to the C4701, the default is usually 5060, and it looks like that is what your phone is using.
     
  3. tpaulas

    Joined:
    Oct 27, 2009
    Messages:
    2
    Likes Received:
    0
    Hi, thank you for reply.

    I set STUN server to stun.3cx.com, registration succeded again, but still private IP in the log and no voice.
    Router at remote extension side is Zyxel P320W and no other system is using port 5060.

    I also setup other VOIP providers on C470IP phone and those are functioning well. I can call normally and hear other side.

    Any other suggestion ?

    Tomas
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    There is probably a setting in the phone that will cause it to send the public IP rather than the internal, private, IP.
     
Thread Status:
Not open for further replies.