3cx Reports

Discussion in '3CX Phone System - General' started by spring, Jan 14, 2016.

Thread Status:
Not open for further replies.
  1. spring

    Joined:
    Nov 20, 2014
    Messages:
    53
    Likes Received:
    0
    I have upgraded my 3CX version 12.5 to V14 SP2. Everything look fine but i noticed that there is something wrong with report.
    when i generated old reports before date that i upgrade the time was difference with my old report( all reports are 5 hour difference) but if i generate report from the date i already upgrade this new report is correct.
    Does any one meet this issue? Please advise.

    BR
    Spring
     
  2. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    If you upgrade from V12 to V14 I could explain this because in V12 the time in the DB was stored as the actual Server time including the timezone but starting from V12.5, the time in the DB was stored in UTC and was calculated based on timezone settings during generation.

    Are you sure you went from V12.5 to V14 and not from V12 to V14?
     
  3. spring

    Joined:
    Nov 20, 2014
    Messages:
    53
    Likes Received:
    0
    Yes NickD_3CX i am upgrade it from version 12.5 to 14 SP2. if i generate report from date it was upgrade the time and date are correct only the previous report became wrong 5 hours all call reports.
    any solutions?
     
  4. gstone

    Joined:
    Jan 21, 2016
    Messages:
    2
    Likes Received:
    0
    Hi Nick,
    If you upgraded from 12 to 12.5 is there a way to fix the reports so they show the correct timezone again?
     
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    The Support Department does have an internal procedure for adjusting he dates yes. Basically they take the Full Backup from V12, run a carefully written script over it that accesses the CSV files in the backup and adjust the times of the entries and then restore it on the V12.5.

    I would recommend opening a ticket with the Support Department if you can and they should be able to help you with the V12 Backup.
    Alternatively you could try and write a script that would do the above.
     
  6. gstone

    Joined:
    Jan 21, 2016
    Messages:
    2
    Likes Received:
    0
    does this script you run also fix the issue that occurs with new records also that are showing incorrect time?
     
  7. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    New entries that are generated after the restoration of the V12 backup to the V12.5 should have the correct time, only reporting on older entries should have a time lapse.

    If new entries also have the wrong time, it might be that the timezone settings either in the Phone System under Settings -> Pone Provisioning or even the server Time are incorrect. In case of the later, I think you must uninstall, change the server time, restart the server and re-install because the timezone is picked up during the installation.
     
  8. spring

    Joined:
    Nov 20, 2014
    Messages:
    53
    Likes Received:
    0
    Hi NickD,

    After i was upgrade 3CX version 12.5 to 14 SP2 my old report go wrong like that so do you have any solutions?
     
  9. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    Quoting a previous response of mine above:
    Basically, if you still have the V12.5 backup you restored onto V14, then the 3CX Support Team might be able to help you with this, although you should not have this issue moving from V12.5 to V14, hence the "might".

    Alternatively, try adjusting he CSV files with a custom script.
     
Thread Status:
Not open for further replies.