3CX soft-phone client not registering when off home network

Discussion in 'Windows' started by Matthew Grenier, Mar 16, 2017.

?

Does 3CX need to clean up their forums?

  1. Yes

    66.7%
  2. No

    33.3%
Thread Status:
Not open for further replies.
  1. Matthew Grenier

    Joined:
    Mar 16, 2017
    Messages:
    5
    Likes Received:
    0
    I see a lot of messy forum posts about registering a 3cx client from outside of your home network. Lotta BAD advice floating around there... I was having this issue. By default when setting up with the welcome email, it inputs the FQDN for "external location" in the client settings under account set-up... which is fine, IF you have a DNS record set-up at your FQDN (use a portchecking site or utility to check 3cx tunnel at your FQDN, port 5090)... we did not, nor did we have access to change our FQDN settings... so, the real thing to try as a FIRST step (assuming you don't have access to your FQDN, or you just don't feel like messing with it) would be to re-address to the external IP of your 3cx server on the soft-phone client in settings, under accounts, to effectively bypass an improperly set-up FQDN. ... that's how I fixed it/figured it out anyways. It's a band-aid technically, yes, however... who cares!!!! as long as it makes it work!!! I circled the place to switch out your FQDN with your external IP of your 3cx server.
     

    Attached Files:

Thread Status:
Not open for further replies.