3cx softphone on mobile phone

Discussion in '3CX Phone System - General' started by soffcec, Dec 15, 2013.

Thread Status:
Not open for further replies.
  1. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    I have running 3cx Phone system ver. 11 I have no problem connecting SIP phones and Windows 3cx softphone to it, but I cannot connect my iphone and my Android phone to it. I am running 3cx client ont the phones. They both get Hook but whe calling the get Forbidden.
    In the servers log I get :

    14-des.-2013 21:54:49.186 Leg L:40.1[Unknown:] is terminated: Cause: BYE from PBX
    14-des.-2013 21:54:49.137 [CM502001]: Source info: From: "galdisplay"<sip:8050@sip.tsc.is>;tag=xLsUlQyD9EsV2CYmuQNLceo.Qw6dEmE9; To: <sip:8920273@sip.tsc.is>
    14-des.-2013 21:54:49.137 [CM503013]: Call(C:40): Incoming call rejected, caller is unknown; msg=Ivite-IN Recv Req INVITE from 194.105.229.195:60274 tid=PjkXSmstfLHvSMG-.3gPtRMemNR1Zl0Umq Call-ID=esNw3nA92Up6Ooi2OdUhKMQy30O-Bvd0:
    INVITE sip:8920273@sip.tsc.is:5060;transport=TCP SIP/2.0
    Via: SIP/2.0/TCP 194.105.229.195:60274;rport=60274;branch=z9hG4bKPjkXSmstfLHvSMG-.3gPtRMemNR1Zl0Umq
    Max-Forwards: 70
    Contact: "galdisplay"<sip:8050@194.105.229.195:34105;transport=TCP;ob;inst="95dcdd19">
    To: <sip:8920273@sip.tsc.is>
    From: "galdisplay"<sip:8050@sip.tsc.is>;tag=xLsUlQyD9EsV2CYmuQNLceo.Qw6dEmE9
    Call-ID: esNw3nA92Up6Ooi2OdUhKMQy30O-Bvd0
    CSeq: 12566 INVITE
    Session-Expires: 1800
    Min-SE: 90
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Content-Type: application/sdp
    Proxy-Authorization: Digest username="galaxy",realm="3CXPhoneSystem",nonce="414d535c08bd64a837:67f504e2fccf9ec71bf4467f8c830d36",uri="sip:8920273@sip.tsc.is:5060;transport=TCP",response="253d7a61aeab63a90ba5b43c2b32eadc",algorithm=MD5
    Supported: replaces, 100rel, timer, norefersub
    User-Agent: 3CXPhone for Android 11.0.53
    Content-Length: 306
     
  2. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Re: 3cx softphoe on mobile phone

    Were you sure to go to the extensions tab---> other---> and uncheck the box disallow use outside of the LAN.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    I did uncheck the box disallow use outside of the LAN with no luck. But when I config 3cx softphone on Windows PC and use the same extension I did use on the mobile phone, everything works fine. But the same extension or any others does not work on the mobile phone.
     
  4. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    Now i can call the 3cx softphone in Android (Samsung Galaxy) mobile but not call from it. Always get forbidden.
     
  5. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Where are you attempting to call from using the android is it the same location where you are using the softphones or different locaitons? Have you attempted to try to connect using 3cx tunnel and making a call?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    I am calling outside my LAN but I have added all necessary IP addresses to the Whitelist. I am calling from Android from different IP addresses than the other Windows soft phones, but they are are also outside the LAN. But when I call from the Windows 3cx softphone I must put the IP address of my 3cx server into "I am in the office" it does not work if I use "I am out of the office"
    I have never tried to use the 3cx tunnel. First I need to know why I have trouble with connecting from mobile phone but not Windows while both softphones are on external net.
     
  7. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    If youre only connecting when you use "I am in the office" your not truly connecting from outside the LAN as in a "remote user" , it sounds as if your on some type of VPN can you confirm that?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    I am not on any VPN. But I don't worry about that because the mobile phone cannot make outgoing call either configured for "I am in the office" or "I am out of the office" but the it connects to the 3cx server and displays On Hook and can accept calls.
     
  9. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    1
    The SIP domain is probably a mismatch.. you tend to get "forbidden" for remote extensions.

    Settings: Advanced: Settings for Direct SIP Calls: Local SIP domain.
    I put in the external domain name there.
     
  10. soffcec

    Joined:
    Feb 5, 2013
    Messages:
    11
    Likes Received:
    0
    This did work. I had to put SRV record into my DNS. Now I can call from my Android
     
Thread Status:
Not open for further replies.