3CX Softphone Prerequisites

Discussion in '3CX Phone System - General' started by Schrodz, Oct 27, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. Schrodz

    Schrodz New Member

    Joined:
    Apr 21, 2017
    Messages:
    100
    Likes Received:
    14
    Hi,

    What are the prerequisites for 3cx Softphone for Windows? It is only documented that it requires NetFramework 4.7.

    It does not mention anywhere about C++ 2010 and 2015 yet, they install when you install the client.

    We are rolling this out via PDQ, Too many PC's to manually install across our site.
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,248
    Likes Received:
    175
    Hi Schrodz,

    The 3CX Softclient prerequisites are as follows:

    Windows PC - either Windows 10, 8.1, 8 or 7 SP1 (Preferred Windows 10).
    Windows updates performed and Microsoft .Net 4.5.2 or higher (The PBX install needs Net 4.6.1)

    Normally it is the case that you would have Windows firewall turned off and exceptions for the program if running any Antivirus locally.
    Simplify things also if possible by having only one IP on the machine and a single NIC (disable all un-used adapters).

    Use this as a guide:
    https://www.3cx.com/user-manual/installation-windows/
     
  3. Schrodz

    Schrodz New Member

    Joined:
    Apr 21, 2017
    Messages:
    100
    Likes Received:
    14
    Hi,

    When you install the client, it installs 2010 32Bit C++ and 2015++ I know about Net Frame, just odd how there is no documentation regarding it

    Dan
     
    ClarkEnersen likes this.
Thread Status:
Not open for further replies.