Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3cx softphone sip port

Discussion in 'Windows' started by remy2vad, Dec 22, 2012.

Thread Status:
Not open for further replies.
  1. remy2vad

    Joined:
    Dec 19, 2012
    Messages:
    6
    Likes Received:
    0
    Hi,

    I am using the 3cx softphone as an external extension to 3cx softswitch through internet ( no voip provider).
    When I call from inside to outside and when the callee ( outside) initiate the bye signal the destination port used is not 5060 ( instead the 12126 is used) so with normal port forwarding it does not go through the firewall in fron of the softswitch.
    Why is that ? any help ?
    Tx
    Remy
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    You are on a 3CX phone , external extension to the 3CX PBX, I understand that part, but....who is it that you are calling , the "outside call"? Is it an external call over a VoIP provider, a gateway, another extension? Are you calling from an internal 3CX extension to the remote, 3CX softphone?

    You need to clarify, inside and outside.
     
  3. remy2vad

    Joined:
    Dec 19, 2012
    Messages:
    6
    Likes Received:
    0
    Hi,

    thanks for the reply

    the internal is 3cx softphone and the external is also 3cx softphone , connected thorough internet like a remote extension no voip provider. I call it external call or outside call referring to local ip segment and the remote ip segment where the external softphone resides although it register itself through the 3cx system in the local ip segment.

    I have also noticed that 12126 port is created and placed into the content header of sip once the ack of the answer call is sent back to the caller. So when the callee try to cut the communication the bye signal is sent to the caller port 12126 and not 5060 like there is a direct comm. between the caller and called . The SIP proxy is bypassed.

    Tx
    Remy
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    It may have something to do with port translations, and the settings/make/model of the routers involved. Do you see the same behaviour if the remote 3CX phone is used at a different location...no? Then look into the router at the PBX end. If you post the make/model, someone on the forum may be familiar with it and can offer advice on any changes that are required. You might also try a search of the forum for any setting changes (features that might need to be disabled), for that model.
     
  5. remy2vad

    Joined:
    Dec 19, 2012
    Messages:
    6
    Likes Received:
    0
    Thanks for the reply,

    It seems that the problem is about caller identification,

    The outside extension register itself correctly and it's placed at 102@2.x.x.x, while 102 is defined locally in the pbx and authentication is correct as 102 is registered and provisonned.
    But when I call *777 or an internal extension (101) I have in the server activity log:

    23-Dec-2012 20:31:49.234 Leg L:1.1[Unknown:] is terminated: Cause: BYE from PBX
    23-Dec-2012 20:31:49.187 [CM502001]: Source info: From: "102"<sip:102@xx.59.75.xxx:5060>;tag=ef2c0350; To: <sip:101@xx.59.75.xxx:5060>
    23-Dec-2012 20:31:49.187 [CM503013]: Call(C:1): Incoming call rejected, caller is unknown; msg=Ivite-IN Recv Req INVITE from xx.147.149.xxx:62212 tid=0f0e3941e1556e30 Call-ID=ZTVmOTYxMTM0YTRmZDRlZjgxNWNhZWU4NjhhMDU4ZWY.:
    INVITE sip:101@xx.59.75.xxx:5060 SIP/2.0
    Via: SIP/2.0/UDP xx.147.149.xxx:62212;branch=z9hG4bK-d8754z-0f0e3941e1556e30-1---d8754z-;rport=62212
    Max-Forwards: 70
    Contact: <sip:102@xx.147.149.xxx:62212;transport=UDP>
    To: <sip:101@xx.59.75.xxx:5060>
    From: "102"<sip:102@xx.59.75.xxx:5060>;tag=ef2c0350
    Call-ID: ZTVmOTYxMTM0YTRmZDRlZjgxNWNhZWU4NjhhMDU4ZWY.
    CSeq: 2 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REGISTER, SUBSCRIBE, NOTIFY, REFER, INFO, MESSAGE
    Content-Type: application/sdp
    Proxy-Authorization: Digest username="102",realm="3CXPhoneSystem",nonce="414d535c06e7c9fc17:f983ff7ae6e96a4b80db6fb2a2b09e30",uri="sip:101@xx.59.75.xxx:5060",response="ffe1827becc2a9c7fe7669e95f534aa5",algorithm=MD5
    Supported: replaces
    User-Agent: 3CXPhone 6.0.26523.0
    Content-Length: 281


    102 and 101 have SIP IDs and other settings seems to be set as the guide.
    it seems 3cx does not like the comm directly placed from a remote extension
    I guess no solution unless using VOIP provider or tunnel.
    Tx
    remy
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    What IP and port is the phone originally registering with? How does that compare to the INVITE? Have you tried calls from a different remote location (behind a different router)?
     
  7. remy2vad

    Joined:
    Dec 19, 2012
    Messages:
    6
    Likes Received:
    0
    Hi,

    The softphone register correctly same as the contact socket of the invite packet.

    I created a trunk VOIP and it is working as it should now, but i think unless i use a tunnel the remote extension will not be accepted.

    Tx
    remy
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,086
    Likes Received:
    325
    So...what is working now, the remote extension, or local calls out on a VoIP trunk?

    As long as all of the settings are correct, and there is no issue with a router at either end, the remote extension should function without having to use the tunnel option.

    You need to attempt to use the remote extension at another location, to eliminate the router, at the current location, as the cause of your problem.
     
Thread Status:
Not open for further replies.