Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX SPA3102 failure to make PSTN inbound/outbound calls?

Discussion in '3CX Phone System - General' started by Mark3XP, Feb 21, 2010.

Thread Status:
Not open for further replies.
  1. Mark3XP

    Joined:
    Feb 21, 2010
    Messages:
    4
    Likes Received:
    0
    Having spent no less than weeks trying to config the 3CX to work in my home I still have some hurdles ;-(

    Background: I thought IP telephone in new house would be good idea. After reading bought the following: Laptop to host 3CX (win XP), Snom 870. I managed to get IP internal network calls working and SKYPE working (yipee). I then discovered not possible to make PSTN calls so bought also a Linksys SPA 3102 as it is supported by 3CX. The SPA3102 is conneted to the laptop hosting 3CX via a router.

    Problem: Setup the SPA3102 and can still mak all my IP internal and skype calls; the 'Analogue Gateway' is registered(idle) and the outbound rule appears to be OK. From PSTN, incoming calls just does not reach the PBX and my outgoing calls terminate immediately. I receive the following in the log file:

    15:18:33.448 [CM503008]: Call(3): Call is terminated
    15:18:33.148 [CM503007]: Call(3): Device joined: sip:10003@192.168.1.105:5062
    15:18:33.128 [CM503007]: Call(3): Device joined: sip:100@192.168.1.109:3072;line=5pcbubo6
    15:18:33.068 [CM505002]: Gateway:[Analogue Gateway] Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA3102-5.1.10(GW)] PBX contact: [sip:10003@192.168.1.123:5060]
    15:18:33.068 [CM503002]: Call(3): Alerting sip:10003@192.168.1.105:5062
    15:18:32.977 [CM503025]: Call(3): Calling PSTNline:621XXXXXX@(Ln.10003@Analogue Gateway)@[Dev:sip:10003@192.168.1.105:5062]
    15:18:32.867 [CM503004]: Call(3): Route 1: PSTNline:621XXXXXX@(Ln.10003@Analogue Gateway)@[Dev:sip:10003@192.168.1.105:5062]
    15:18:32.857 [CM503010]: Making route(s) to <sip:0621XXXXXX@192.168.1.123:5060;user=phone>
    15:18:32.847 [CM505001]: Ext.100: Device info: Device Identified: [Man: Snom;Mod: 8xx series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [snom870/8.3.2] PBX contact: [sip:100@192.168.1.123:5060]
    15:18:32.747 [CM503001]: Call(3): Incoming call from Ext.100 to <sip:0621XXXXXX@192.168.1.123:5060;user=phone>

    Not sure if my PSTN Line config is correct for LUXEMBOURG (P&T); in fact not really sure if this is the real problem but it appears it may be. The 3CX guide says to not enable line 1 - perhps I should try to get this to work first before trying to use 3CX also (?).

    Would be very grateful if someone could point me in the right direction as my wife is seriously asking why I spend so much time, effort and money trying to setup this when a simple analogue phone for £20 would of been much better (well it would work she correctly says). Now using mobiles for all calls. PLEASE HELP as I think this could be really great setup and I feel pretty close to getting it to work (just PSTN Voice Gateway is the final hurdle) ;-/
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    This can cause some issues but usually only things like echo or caller ID, if left at the defaults. Not sure what settings you'd use for your country but I'm sure someone in Luxembourg has set up a 3102 before, just a matter of doing a search on the net. Try doing a search for a country that uses the same caller Id settings, perhaps Germany or Belgium?.

    You can use both the FXO and FXS ports on the 3102 with no problem ( I have 3 units working just fine), however, there are a number of settings in the 3102 that allow calls to pass between the line and phone jacks and to not be directed to 3CX. These have to be disabled. If you do a search for "3102" in the 3CX forums, you will find a large number of posts from people that have had various problems, along with the solutions (in most cases).

    Make sure that the port number in the 3102, for the FXO jack/socket, has been changed from the default of 5061, to 5062, which is what 3Cx expects to "talk" to it on.

    If you look in the 3102 , go to the Voice / Info tab, it will show you the status of the PSTN line near the bottom. It will also tell you what happened to the last call, what number was dialed, if it is On Hook/idle, etc.
     
  3. webguyz

    webguyz New Member

    Joined:
    Jul 19, 2007
    Messages:
    126
    Likes Received:
    0
    Try turning on STUN server in the SPA3102. I see a lot of private IP's in the log example you have and to talk to the outside world it requires public ips. I interfaced a Ooma Telo using a SPA3102 and I did turn on STUN server because the SPA3102 is behind a firewall. After that it was working well.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    You won't need STUN on any internal device except 3Cx itself as it can communicates with VoIP providers. In fact you can cause problems tuning it on. In this case the 3102 does NOT have to pass through a firewall.
     
  5. Mark3XP

    Joined:
    Feb 21, 2010
    Messages:
    4
    Likes Received:
    0
    Good evening,

    Getting a little late now on a Sunday evening. Many thanks for your input. You have both inspired me to persist further (nice knowing that people as there to help!). When I get time (probably next w/e) I shall do some more searching on the forum in addition to investigating what you have both suggested. I shall keep you both posted and once again thanks for you input thus far.

    I do know that this technology can do what I require of it; it is just figuring out how.

    Anyhow - I wish you both a nice evening.

    Best regards,

    Mark
     
  6. Mark3XP

    Joined:
    Feb 21, 2010
    Messages:
    4
    Likes Received:
    0
    Good evening,

    Decided to go back to first principles and get analogue phone working first. Please see my new post.

    CHEERS
     
Thread Status:
Not open for further replies.