3cx still sending ghost registrations to sip provider with old WAN IP

Discussion in '3CX Phone System - General' started by oleman, Jan 9, 2017.

Thread Status:
Not open for further replies.
  1. oleman

    Joined:
    Jan 23, 2009
    Messages:
    7
    Likes Received:
    0
    2 things happened: We have a new wan IP in our office line (ends in 110). And I moved 3cx to new hardward by means of backup and restore.
    Small note: The lan ip of the 3cx was different during initial setup, shouldn't have done that, this meant I had to change all the lan ip's in custom paramaters, not a problem, it all works now, I'm including this because it may be related to the real issue.

    After the installation and migrations, everything works fine, except that when I come in to the office in the morning, the trunk status is registered but calls cannot be made, they are refused by the provider.

    Talked to the provider and they see a second registration comming in from a wan IP address that ends in 247 which happens to be our old office IP, that was changed a few weeks ago.

    So, what happens is, the correct registration comes in from wan IP 110, provider accepts, registered, everything works fine. 20 minutes later, a second registration comes in from ip 247 (with exact same paramaters so to much coincidence for it to be an actual different party trying to register using our credentials). The second registration is refused by the provider and the first is gone too.

    What i've done: Searched activity log, (verbose mode). The 110 (correct) registrations are clearly listed. Used the log viewer, searched custom paramaters and in all those I can find the 110 ip addres set as wan and being sent out, but not the 247 address being sent out, and it clearly is.

    Does anybody have any idea how 3cx could be sending out old registrations using old ip adres? Any ideas where I should look to at least find mention of this old ip?


    Looking forward to any suggestions
    Thanks
    n.b. we did fix it by blocking regs coming in from 247, just still very curious how 3cx could be sending out ghost registrations
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Hello @oleman

    Not sure what is going on, never seen this before but it sounds like something is stuck.
    I would recommend deleting the provider from the PBX, restarting the (windows) machine and re adding the provider.
    Also when changing local IP address you should always create a backup without license and FQDN and restoring again.
     
  3. oleman

    Joined:
    Jan 23, 2009
    Messages:
    7
    Likes Received:
    0
    Thanks for the reply.. I tried deleting and adding the provider but no luck.. I'ts a bit of a mess I'm afraid.
    I have to try some things and it looks like I may have to rebuild the server from the start, it's not a very complex config though.
    Thanks again.
     
  4. John Ranger

    Joined:
    Jan 14, 2017
    Messages:
    23
    Likes Received:
    8
    Hi Oleman,

    as the Registration of the wrong IP comes at a different time compared to the registration of the correct IP, I would expect that the old 3CX Installation is somehow still running, trying to Register itself in parallel to the new Installation.

    If you think that this can be ruled out: Stop the new 3CX in an off-business-hour and check then with the VoiP Provider if they still see the old/wrong IP gets registered. --> If this is the case, then there must be the old Installation still running somewhere (must not be neccessary on the box with the IP x.x.x.247 because the registering IP can be configured within the trunk Settings of 3CX).

    If after disabling the new 3CX Installation this does not anymore occur, then it must be in the configuration of your new 3CX Installation.

    It is then most probably, that in your SIP trunk configuration of the new Installation (you did a backup of the old System and imported that into the new System, right?) there is an Option to hard-code the IP address under which the trunk will Register itself (in V15, this is within the SIP trunk configuration --> Options and the Setting is called: "Select which IP to use in 'Contact' (SIP) and 'Connection'(SDP) fields" --> Make sure there is your new IP x.x.x.110 configured).

    Hope this helps.

    With Kind regards,

    John Ranger
     

    Attached Files:

    datamerge likes this.
Thread Status:
Not open for further replies.