Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX TLS problem

Discussion in '3CX Phone System - General' started by miro, Feb 1, 2012.

Thread Status:
Not open for further replies.
  1. miro

    Joined:
    Jan 17, 2012
    Messages:
    51
    Likes Received:
    0
    Hi,

    we have 3cx on a public ip, we tested sip TLS from the internet and it is working fine. problem is when we move 3cx behind the ruter and put it on the private IP, we cannot register our 3cx softphone from outside (Internet). internal everthing is ok, so certificate is good...

    In the firewall we allow 5061 and forward that port to internal ip on our 3cx internal ip on our 3cx, we can see that packet are hits our rule on the firewall and that traffic is coming to our 3cx.

    In server activity log there is a log: Got TLS read ret=0 error=6 error:00000006:lib(0):func(0):EVP lib


    Please help, thanks.
     
  2. miro

    Joined:
    Jan 17, 2012
    Messages:
    51
    Likes Received:
    0
    We also tried with Yealink SIP phone, and it was successfully registered over TLS via Internet, but no RTP, over 3CX softphone doesnt work.

    Please help anyone.
     
  3. miro

    Joined:
    Jan 17, 2012
    Messages:
    51
    Likes Received:
    0
    More result from testing

    Yealink phone:

    registered when 3CX PBX directly connected over public IP address and if 3CX is behind router/firewall/nat in both situation Yealink which is external extension cannot hear voice (RTP) and opposite side can hear voice in both situation.

    3CX softphone:

    directly connected to the Internet 3CX PBX, softphones are registered and RTP is working on both side, when 3CX PBX behind NAT softphone cannot registered.
    We also tried with STUN, but with no luck.

    Please help, thanks.
     
  4. akbar.azwir

    Joined:
    Jul 23, 2012
    Messages:
    1
    Likes Received:
    0
    Hi,

    We are facing the same problem, has anyone found the solution for this?

    Thank you.
     
Thread Status:
Not open for further replies.