3CX to FlowRoute Outbound Call Failure

Discussion in '3CX Phone System - General' started by Whitey436, Mar 26, 2015.

Thread Status:
Not open for further replies.
  1. Whitey436

    Joined:
    Mar 26, 2015
    Messages:
    3
    Likes Received:
    0
    I am running a new 3CX V12.5 server install with FlowRoute. It has never worked as of yet. I have Cisco 7960s and a couple Android extensions. The Firewall Checker runs successfully but I cannot make any outbound calls. Any help would be appreciated.

    Here are the log entries.

    26-Mar-2015 17:19:32.263 Leg L:5.1[Extn] is terminated: Cause: BYE from PBX
    26-Mar-2015 17:19:32.213 [CM503020]: Call(C:5): Normal call termination. Call originator: Extn:102. Reason: Forbidden
    26-Mar-2015 17:19:32.213 L:5.1[Extn] failed to reach Line:10000>>14073731234, reason Forbidden
    26-Mar-2015 17:19:32.211 Leg L:5.2[Line:10000>>14073731234] is terminated: Cause: 403 IP Based Authentication Required - support@flowroute.com/INVITE from 216.115.69.144:5060
    26-Mar-2015 17:19:32.211 Call to T:Line:10000>>14073731234@[Dev:sip:27602217@sip.flowroute.com:5060] from L:5.1[Extn] failed, cause: Cause: 403 IP Based Authentication Required - support@flowroute.com/INVITE from 216.115.69.144:5060
    26-Mar-2015 17:19:32.209 [CM503003]: Call(C:5): Call to <sip:14073731234@sip.flowroute.com:5060> has failed; Cause: 403 IP Based Authentication Required - support@flowroute.com/INVITE from 216.115.69.144:5060
    26-Mar-2015 17:19:31.878 [CM503025]: Call(C:5): Calling T:Line:10000>>14073731234@[Dev:sip:27602217@sip.flowroute.com:5060] for L:5.1[Extn]
    26-Mar-2015 17:19:31.833 [CM503027]: Call(C:5): From: Extn:102 ("Android" <sip:102@192.168.1.1:5060>) to T:Line:10000>>14073731234@[Dev:sip:27602217@sip.flowroute.com:5060]
    26-Mar-2015 17:19:31.833 [CM503004]: Call(C:5): Route 1: from L:5.1[Extn] to T:Line:10000>>14073731234@[Dev:sip:27602217@sip.flowroute.com:5060]
    26-Mar-2015 17:19:31.833 Line limit check: Current # of calls for line Lc:10000(@Flowroute[<sip:27602217@sip.flowroute.com:5060>]) is 0; limit is 10
    26-Mar-2015 17:19:31.833 Call(C:5): Call from Extn:102 to 14073731234 matches outbound rule 'Rule for Flowroute'
    26-Mar-2015 17:19:31.832 [CM503001]: Call(C:5): Incoming call from Extn:102 to <sip:14073731234@192.168.1.1:5060>
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,362
    Likes Received:
    227
    The 3CX set-up instructions from Flowroute seem pretty straight forward..

    https://support.flowroute.com/customer/portal/articles/1849185-3cx-phone-system---add-flowroute-as-voip-provider

    But your logs would seem to indicate that the authentication method that you are using, is not working (they don't like it).

    You may want to contact them for more information about this.

    Did they ask you to provide them with a static IP that your calls will originate from?
     
  3. Whitey436

    Joined:
    Mar 26, 2015
    Messages:
    3
    Likes Received:
    0
    Yes, I did add my external static IP to the authenticated outbound call list on the FlowRoute site.
    Thanks for pointing me in the right direction. I felt like the 3CX setup process was pretty easy as you said.
    I will contact FlowRoute and post my results.

    Thanks!
     
  4. Whitey436

    Joined:
    Mar 26, 2015
    Messages:
    3
    Likes Received:
    0
    I contacted FlowRoute and they were able to help solve the issue.
    Admittedly, it was a 3CX config issue not something on the FlowRoute side.

    While the 3CX config for FlowRoute is straight forward, there really needs to be two options:
    SIP Authentication or IP Based Authentication.

    I was intending on using IP-Based and had configured FlowRoute as such. The message back from FR when attempting the call confirmed that they needed IP-Based configuration to be delivered to them in order to complete the call.

    **
    In order to support IP-based authentication on the 3CX to FlowRoute, which is NOT included in the current config notes, is that you must modify the Outbound Rules to PREPEND your FlowRoute 'Tech Prefix' plus an '*' to any outbound call.
    **
    As soon as I added this to my rules, my calls worked perfectly.

    Thanks for your help on this matter.
     
  5. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,962
    Likes Received:
    180
    Thanks for posting this tip - I was wondering how to do IP Auth with Flowroute.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.