3cx Tunnel one way audio

Discussion in 'Windows' started by MB1, Oct 4, 2013.

Thread Status:
Not open for further replies.
  1. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    Hi,

    I'm in the UAE (Dubai) at the moment. UAE are notorious for blocking SIP calls, so I am trying to setup the 3CX tunnel app on an iPhone. The tunnel connects fine, and the 3CX phone app registers, but I can only achieve oneway audio. I have tried connecting using various port combinations 5090, 8000 etc. but with the same results.

    I am able to use a program called Teamviewer (control a remote PC over a secure connection) perfectly. I assume that Teamviewer requires an encrypted two way connection much the same as 3cx tunnel?

    Any ideas anyone?

    Thanks in advance.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    229
    I'm not aware of the 3CX tunnel being encrypted. My understanding is that it simply allows everything to be run over one port to allowing you to overcome some NAT issues. I find it is the tool of second to last resort when not being able to register at a hotspot. The last resort is VPN.

    You are trying to use it from an area that is actively blocking VoIP, means that they can probably still "see" that VoIP packets are attempting to "get through". While you may end up getting it to work, others on the forum, with this issue, have had to go to a VPN connection, as it is encrypted.
     
  3. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi,

    I think I have exactly the same problem as MB1, and I am not in the UAE.
    The tunnel connects fine, the 3CX phone app registers, but I can only achieve oneway audio.
    I have audio from iPhone to 3CX server, but no audio from 3CX server to the iPhone.
    If using the 3CXPhone app without the tunnel everything works fine. :)
    Enable “PBX delivers audio” does not solve the problem.

    I am using: iPhone 3GS 6.1.3, 3CXPhone 12.0.5, 3CX VoIP Tunnel 1.0.0 and a 3G internet connection.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    229
    Did it work using the previous version? Did it ever work on this version (12)?

    I'm wondering if it is some sort of hardware issue on the PC? Are you using an analogue headset, USB, Bluetooth? Have you tried running the 3CX phone an any other PC's? What operating system are you running on the PC?
     
  5. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi leejor,

    Thanks for your reply.

    I am afraid we have a little miscommunication. :shock:

    I have audio problems with the 3CXPhone for iPhone (same as MB1), not with the 3CXPhone for Windows.
    If I use the 3CXPhone for iPhone without the Tunnel app, it work fine. So, no ports are blocked by the ISP/TSP.
    If I use the 3CXPhone in combination with the Tunnel app then I have a one-way audio issue. (same as MB1)
    It looks like the problem is caused by the Tunnel app.
    3CX Server Activity Log shows no problems.

    Not having this problem when using the old version of 3CXPhone v1.1.5 and Tunnel v1.0.0 and 3CXPhone System v10.
    I have an audio issue with 3CXPhone for iPhone v12.0.5 with Tunnel v1.0.0 and 3CXPhone System v12 SP1. Again, without the Tunnel app everything is OK.

    Hope it is somewhat more clearly now.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    229
    Sorry, because the original post wasn't in the 3CX iPhone forum, I wrongly assumed that he was using the IPhone only in addition to, the Windows version.
     
  7. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    Hi,

    I was unaware that 3CX Tunnel wasn't encrypted and therefore the VOIP packets are visible. Does anyone know a way around this using an IPHONE, perhaps a VPN app?

    Thanks in advance.

    MB1
     
  8. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi MB1,

    At the company site I use a Draytek router with VPN (PPTP Remote Dial-in) enabled.
    On the iPhone I setup a VPN PPTP connection with the router so that I can make successful calls.
    This does work in the Netherlands, also successful tested in other parts of the world.
    At the end of this month I am going to the UAE and Oman and I am very curious if it stay working.
    I will tested with and without a VPN connection.
    We will see. :D

    Update:
    I have found a Free VPN Service for iPhone.
    Maybe it is something, maybe it is nothing. Give it a shot, you’ve got nothing to lose.
    http://www.hotspotshield.com/

    Good luck. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. MB1

    MB1

    Joined:
    Nov 2, 2007
    Messages:
    39
    Likes Received:
    0
    Hi Complex1,

    Thanks for the VPN App, i'll give it a go.

    I would be very interested to hear how you get on in the UAE. If all else fails try FaceTime,it worked yesterday at least!

    Cheers,

    MB1
     
  10. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi MB1,

    As requested a feedback of the made phone calls during my stay in the UAE and Oman.
    In the UAE and Oman services like Skype, Viber and sometimes You-Tube are blocked by government.

    The test is done with an iPhone 3GS - iOS 6.1.3 - build-in VPN and 3CXPhone v 12.0.5.
    The 3CX PBX is located in the Netherlands and connected to the Internet via a Draytek router and DynDNS.
    Before going to the UAE/Oman I have tested the settings. I could not get the 3CX Tunnel app (v1.0.0) to work properly. I have one-way audio, but via Wi-Fi and 3G -with/without VPN- everything is working as it should work, so I decide not to use the Tunnel app.

    All phone calls were made in the UAE (Abu Dhabi, Dubai and Ras Al-Khaimeh) and Oman (Nizwa, Ras Al-Hadd and Muscat) via Wi-Fi.

    First I establish an Internet connection via Wi-Fi, then setup a VPN connection to the business router.
    After the iPhone has got his local IP-address from the router DHCP, 3CXPhone v12 is started. The 3CXPhone registered successfully and calls can be made/receive. 3CXPhone is connected as “in Office”.
    The quality of the connection is very depending of the Internet lag/jitter. Sometimes I had a voice delay of more than 2 sec. and sometimes no delay at all, but in general I had no delay and voice was very clearly.

    If I didn’t use VPN, the 3CXPhone was connected as “Out of Office”, but I could not dial any number.
    The phone was registered to 3CX PBX with an external IP-address, but that was all.

    Conclusion: If you setup things properly you can make and receive calls in the UAE and Oman and -also very important- you are depending on the quality of your Internet connection.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    You can change the default 3CX tunnel port from 5090 to 80 or 443, those ports looks like are not blocked into UAE and other countries, blocking VoIP. Even 3CX tunnel is not encrypted, it is a kind of GRE tunnel, I don't believe anyone being inspecting packets so deeply (requires lots of computer power and will delay the traffic). Some of my customers said they changed the tunnel port successfully and avoided blocking of VoIP traffic.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.