Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX Tunnel

Discussion in 'iOS' started by thomassn, Jun 23, 2012.

Thread Status:
Not open for further replies.
  1. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    Hi,

    Im trying to get my 3CX Tunnel working to get my iPad connect via 3G to my 3CX server.

    I have made following nat on my router and enabled SIP ALG (got a Linksys E3000)

    However the 3CX Tunnel keep trying to connect but it cant connect. What have I done wrong ? The 3CX iPhone app worked out fine by WiFi
     
  2. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    Remove in your route “3CX Intern 7000-7499” and add “3CX Tunnel 5090-5090”
    Also Disable SIP ALG.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    Done as you wrote. Thx the answer even on a saturday :p However it didnt help me.

    My 3CX Tunnel settings at my iPad: attachment 1

    3CX Tunnel settings at Management Interface: attachment 2
     

    Attached Files:

    #3 thomassn, Jun 23, 2012
    Last edited by a moderator: Apr 27, 2017
  4. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    Oh I just saw the post about posting topics :)

    My iPad is a iPad2 3G+WiFI 32GB with 5.1.1 iOS and not jailbreaked!

    My Router is a Linksys E3000

    My server is installed on Windows Server 2008 R2 with SP1 in a VMware Workstation. The network card in the virtual machine is set to Bridge Mode and gets the IP-address from the DHCP-server in the Linksys E3000
     
  5. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    Have you run the firewall checker without any errors?
    For security reasons, please use a more secure password for your tunnel.
    It is not recommended to use a dynamic address for your 3cx server, please use a static one.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    Code:
    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.
    
    <10:33:08>: Phase 1, checking servers connection, please wait...
    <10:33:08>: Stun Checker service is reachable. Phase 1 check passed.
    <10:33:08>: Phase 2a,  Check Port Forwarding to UDP SIP port, please wait...
    <10:33:13>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.
    
    <10:33:13>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <10:33:18>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.
    
    <10:33:18>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <10:33:23>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.
    
    <10:33:23>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <10:33:34>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <10:33:39>: UDP RTP Port 9001. Response received correctly with no translation. Phase 4-02 check passed.
    <10:33:44>: UDP RTP Port 9002. Response received correctly with no translation. Phase 4-03 check passed.
    <10:33:48>: UDP RTP Port 9003. Response received correctly with no translation. Phase 4-04 check passed.
    <10:33:53>: UDP RTP Port 9004. Response received correctly with no translation. Phase 4-05 check passed.
    <10:33:57>: UDP RTP Port 9005. Response received correctly with no translation. Phase 4-06 check passed.
    <10:34:02>: UDP RTP Port 9006. Response received correctly with no translation. Phase 4-07 check passed.
    <10:34:06>: UDP RTP Port 9007. Response received correctly with no translation. Phase 4-08 check passed.
    <10:34:11>: UDP RTP Port 9008. Response received correctly with no translation. Phase 4-09 check passed.
    <10:34:15>: UDP RTP Port 9009. Response received correctly with no translation. Phase 4-10 check passed.
    <10:34:20>: UDP RTP Port 9010. Response received correctly with no translation. Phase 4-11 check passed.
    <10:34:24>: UDP RTP Port 9011. Response received correctly with no translation. Phase 4-12 check passed.
    <10:34:29>: UDP RTP Port 9012. Response received correctly with no translation. Phase 4-13 check passed.
    <10:34:33>: UDP RTP Port 9013. Response received correctly with no translation. Phase 4-14 check passed.
    <10:34:38>: UDP RTP Port 9014. Response received correctly with no translation. Phase 4-15 check passed.
    <10:34:43>: UDP RTP Port 9015. Response received correctly with no translation. Phase 4-16 check passed.
    <10:34:47>: UDP RTP Port 9016. Response received correctly with no translation. Phase 4-17 check passed.
    <10:34:52>: UDP RTP Port 9017. Response received correctly with no translation. Phase 4-18 check passed.
    <10:34:56>: UDP RTP Port 9018. Response received correctly with no translation. Phase 4-19 check passed.
    <10:35:01>: UDP RTP Port 9019. Response received correctly with no translation. Phase 4-20 check passed.
    <10:35:05>: UDP RTP Port 9020. Response received correctly with no translation. Phase 4-21 check passed.
    <10:35:10>: UDP RTP Port 9021. Response received correctly with no translation. Phase 4-22 check passed.
    <10:35:14>: UDP RTP Port 9022. Response received correctly with no translation. Phase 4-23 check passed.
    <10:35:19>: UDP RTP Port 9023. Response received correctly with no translation. Phase 4-24 check passed.
    <10:35:23>: UDP RTP Port 9024. Response received correctly with no translation. Phase 4-25 check passed.
    <10:35:28>: UDP RTP Port 9025. Response received correctly with no translation. Phase 4-26 check passed.
    <10:35:33>: UDP RTP Port 9026. Response received correctly with no translation. Phase 4-27 check passed.
    <10:35:37>: UDP RTP Port 9027. Response received correctly with no translation. Phase 4-28 check passed.
    <10:35:42>: UDP RTP Port 9028. Response received correctly with no translation. Phase 4-29 check passed.
    <10:35:46>: UDP RTP Port 9029. Response received correctly with no translation. Phase 4-30 check passed.
    <10:35:51>: UDP RTP Port 9030. Response received correctly with no translation. Phase 4-31 check passed.
    <10:35:55>: UDP RTP Port 9031. Response received correctly with no translation. Phase 4-32 check passed.
    <10:36:00>: UDP RTP Port 9032. Response received correctly with no translation. Phase 4-33 check passed.
    <10:36:04>: UDP RTP Port 9033. Response received correctly with no translation. Phase 4-34 check passed.
    <10:36:09>: UDP RTP Port 9034. Response received correctly with no translation. Phase 4-35 check passed.
    <10:36:13>: UDP RTP Port 9035. Response received correctly with no translation. Phase 4-36 check passed.
    <10:36:18>: UDP RTP Port 9036. Response received correctly with no translation. Phase 4-37 check passed.
    <10:36:22>: UDP RTP Port 9037. Response received correctly with no translation. Phase 4-38 check passed.
    <10:36:27>: UDP RTP Port 9038. Response received correctly with no translation. Phase 4-39 check passed.
    <10:36:32>: UDP RTP Port 9039. Response received correctly with no translation. Phase 4-40 check passed.
    <10:36:36>: UDP RTP Port 9040. Response received correctly with no translation. Phase 4-41 check passed.
    <10:36:41>: UDP RTP Port 9041. Response received correctly with no translation. Phase 4-42 check passed.
    <10:36:45>: UDP RTP Port 9042. Response received correctly with no translation. Phase 4-43 check passed.
    <10:36:50>: UDP RTP Port 9043. Response received correctly with no translation. Phase 4-44 check passed.
    <10:36:54>: UDP RTP Port 9044. Response received correctly with no translation. Phase 4-45 check passed.
    <10:36:59>: UDP RTP Port 9045. Response received correctly with no translation. Phase 4-46 check passed.
    <10:37:03>: UDP RTP Port 9046. Response received correctly with no translation. Phase 4-47 check passed.
    <10:37:08>: UDP RTP Port 9047. Response received correctly with no translation. Phase 4-48 check passed.
    <10:37:12>: UDP RTP Port 9048. Response received correctly with no translation. Phase 4-49 check passed.
    <10:37:17>: UDP RTP Port 9049. Response received correctly with no translation. Phase 4-50 check passed.
    
    
    Application exit code is 0
    
    The 3CX is using a static address which are excluded by the DHCP server
     
  7. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    The result of the firewall checker looks good.

    If you are running a Anti Virus and a Firewall protection, please turn both temporarily off.

    Type on a other PC “Telnet <ip-add of 3CX server> dash 5090” and see if you get a connection with the 3CX server. It shows a few random characters, then nothing for a few seconds, then a text like “the connection is lost” or something like that.
    When I am trying to Telnet your IP (62.116.212.58), I get no response.

    If you are trying to connect your iPad via the tunnel with 3CX, do you see an attempt, in the 3CX log, to set-up the tunnel?

    Have you double-checked the tunnel password (3CX and iPad), local and remote Tunnel IP?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    I changed the tunnel password and it helped. The 3CX Tunnel is up and running.

    My iPad 2 reports following:
    Tunnel connected

    Request Timeout/Not registered

    Serverlog:
    12:27:14.552 [CM503016]: Call(1): Attempt to reach <sip:102@192.168.1.50:5060> failed. Reason: Not Registered
    12:27:14.552 [CM503017]: Call(1): Target is not registered: Ext.102

    I have turned on 3CXPhone Provision and I have unselected Disallow use of extension outside the LAN
     
  9. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    Ok, now you have a tunnel up and running, but this will not say that ext. 102 (iPad) is registered with the 3CX server.
    There is a good description how to register a iPhone/iPad with 3CX.
    Please read this first.
    http://www.3cx.com/blog/3cxphone/iphone/configuring/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    I followed the manual (your link) but it didnt helped.
     

    Attached Files:

  11. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Hi,

    The PBX port must be 5060 instead of 5090
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. thomassn

    Joined:
    Jun 23, 2012
    Messages:
    7
    Likes Received:
    0
    Successful :D

    Thx you very much :D
     
  13. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    813
    Likes Received:
    46
    Your welcome.
    The pleasure is on my side. :D
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. Twilio

    Joined:
    Jun 26, 2012
    Messages:
    4
    Likes Received:
    0
    hi,
    i think it is no difficult...... you just remove your current router 3CX intern 7000-7499 and work in 3CX 5090-5090.......

    and you should disable your SIP ALG from your application......

    it will worth .......... :)
     
Thread Status:
Not open for further replies.